How to increase global GPU particle limit

I am developing a project where I need to spawn particles in absurd quantities. I have tried optimising the actual effects, but I still need to be able to spawn around 5 million of them. There is no lag at all, but at some point the GPU particles just stop spawning. From what I can guess this happens when their total count reaches a million. So I want to ask if it is possible to raise this limit somehow. Thank you in advance.

A simple search on the answerhub resulted in this:

Yes, I have already seen this, however I don’t quite understand it. For instance, is recompiling the engine from scratch the only way? And the post is 4 years old. I hoped there may have been an easier solution implemented since then

I have no seen any in-editor changes or options to alter the max limits, so your only bet is to edit the source code and recompile the engine.

If you dont understand it, and the only way for you is to create absurd quantities of gpu particles you either need to reconsider your approach, or find/pay someone to add these changes and recompile the engine for you.

Thank you for the answer. Well, I have no problem with learning how to recompile, so I’ll get to it, I was just thinking that it seemed rather a conplicated process for the editing of 2 integers

1 Like