Download

How to increase custom depth pass / mask render distance

Hello,

I’m using a custom depth pass to occlude parts of a translucent material. The material is applied to a massively big mesh, and whenever the camera is too far away from this mesh, the custom depth seems to cut off.

Is there a way to increase the distance of this depth pass?

Shameless bump :3

I’d guess that’s r.MinScreenRadiusForDepthPrepass

Probably needs to be made into a Rendering project setting with a less aggressive default to avoid unwanted behavior like this.

Thanks for the reply.

Would it work if I added this line to DefaultEngine.ini? And if yes, what is the default value for this?

EDIT: I tried adding the command to the ini with a rediculously high number (999999999) and also tried it in-game as a console command, both ways don’t make any difference, the clipping still occurs at exactly the same distance. :frowning:

EDIT2: I’ve found the setting as wel under render settings in project settings with a default value of 1000000.0. I tried increasing it but still no change. So it might be something else causing this clipping then?

The material that has the issue uses a translucency sorting issue work around as found in the community ocean project. It uses the depthpass to cull out the backside of each wave, making them not visible when looking directly through a wave.

One reason I don’t think it’s the depthpass rendering distance is that the depthpass shows up fully when I go into depth buffer visualisation mode, No clipping occurs here…

So my guess is that it’s not the render distance of the depthpass but the render distance of translucent materials. Is there a way / setting to increase this render distance?