Download

how to improve lightmass quality for poorly lit rooms?

hi, in my archviz project, there are some rooms that have small windows, others that are not getting direct sunlight, only skylight, and in both cases the lightmass quality is bad. I added lightmass portals to the windows, baked in production quality, but still I get results like this:

how to improve this? must I add some source of artificial light? I mean, how do you bake lighting for a cave in a game for example, where the light conditions are gonna be poor?

Hi!

What are your Lightmass settings?
You can tune a LOT with Postprocess!!

It looks fine to me, but if you have a room that’s naturally dark and you want to be able to see better then you’ll have to add lights. It’s very common in movies for example to add lighting to night scenes, it can get kind of weird where the characters act like they can’t see anything even though you can see things in the image just fine.

In my experience, in scenes where you have mostly indirect sky or emissive lighting you need to crank up the “indirect light quality” quite a lot to get splotch-free results. Try increasing it in increments of 10.

hey thanks for replying guys. turns out this was related to the same thing as another issue I had, posted here:
https://forums.unrealengine.com/deve…htmass-banding
apparently I changed a few settings, uncompressed maps, and it is much better now. check the other thread if you’re having similar issues and think this could help, or if you’re just interested.
cheers!