How to ignore self shadow In Mobile


Device Screenshot.

UE4 Ver : 4.10

Scene Light :

Directional Light(stationary, Cast Modulated Shadow , Cast Static Shadows , Cast Dynamic Shadows)

Sky Light(static , Cast Static Shadows )

Model: Skeletal Mesh (2Part)

self shadow broken in mobile device.

How to ignore self shadow in Skeletal Mesh? not self shadow only.

We were testing alllll day :frowning:

we tested[4.9.2 Full source], [4.10.1 Full source], [4.10.2 Full source] , [4.11 Peview4 Full source] , [4.11 launcher]

test PC spec

  • i5 2500k , GTX-680
  • VS2013 ,VS 2015 Update1

-test project
3rd person templete. (No edit)
Light Source(Directional Light) is Stationary and Cast Modulated Shadows check

-test device
iphone4s ,iphone5 , iphone5s , iphone6 , iphone6s

-Device profile
No edit. standard.

and result
[4.9.2 Full source , VS2013]
iphone4s → good

iphone5 → good

iphone5s → flickering

iphone6 → flickering

iphone6s → flickering

[4.10.1 Full source , VS2015 update1]

iphone4s → good

iphone5 → good

iphone5s → flickering

iphone6 → flickering

iphone6s → flickering

[4.10.2 Full source , VS2015 update1]
iphone6 → flickering

[4.11 Peview4 Full source , VS2015 update1]

iphone6 → flickering
iphone6s → flickering

[4.11 Peview4 Launcher BP only]

iphone6 → flickering

mobile peviewer is always good. but run to deivce like that △

i think stationary directional light bug.

when i tried movable directional light. Displayed well. buy frame drop 15~20. I can’t use it in mobile.

How do I solve this problem?

Hi Ruthless,

What type of device are you using when you package?

Also, is this only happening on the device or in the editor as well?

Test device : iphone5 , iphone5s , iphone6

shadow broken device only. editor is good.

another test. I use Directional Light (Dynamic)

shadow was not broken. but very low performance. :frowning:

and Test skeletalMesh(1part). shadow was not broken.

Using your settings and steps above I’m not able to see the same issue on the Iphone 5s that I have for testing. I’ve got just a very simple scene setup with two skeletal meshes (TutorialTPP) from the Engine Content folder.

Are you able to recreate this in a blank project with one of the sample assets from the editor/engine folder or any other templates that are provided with the engine? If so, would you mind uploading the project?

Thank you!

To answer your original question, there is no way that I’m aware of to disable self shadowing.

we test 4.11 peview.
shadow broken only iphone6

Are you able to provide a sample project where that I can test? I’ve not been able to reproduce this yet, so perhaps there is something that I can look at here that will.

i can’t… sorry. :frowning:
I found same issue.

and i can upload Intermediate/config/DeviceProfiles.ini

[iPhone6 DeviceProfile]

I’ll give this some additional testing, but I’ve not been able to reproduce this outside of other users seeing this in their projects. When I asked for a sample project, it can simply use the sample assets that Epic provides with the engine, it does not have to be custom content. If you cannot reproduce outside of your project this would explain why I’m seeing the results I am.

After I run the test in a bit I’ll update your this afternoon on my findings and if I’m able to reproduce.

we test 3rd person example △EDIT

There was no problem when testing with a Stationary Directional Light?

Thank you for all the additional details. I’ve submitted UE-26765 for this particular issue to be looked into.

I’ll update here once there has been a fix internally along with any additional details.

Thank you!


hi. Tim
this issue fix it?

UE-26765 was disappeared in Known Issues list.

but 411 p8 still bug. :frowning:

This has been marked as resolved internally and should be resolved once 4.12 releases. It was removed from 4.11 list because it’s now been marked for 4.12 to have it’s resolution. I’ve not yet been able to verify that this is fixed yet though. I’ll have it verified probably tomorrow if I can get my build issues resolved. I’ll post back once I’ve verified that I’m no longer seeing the issue.