How to hide sky box in render target?

I want to show a pawn on UI, so I added a scenecapture2d in the level, but there are so many things except pawn in the rendertarget ( sky box, water…), I don’t want to display these things. How to hide these things?

You could set the far-clipping plane on the camera you’re capturing from to a lower value, and that should clip out the background stuff.

It does work for some meshes in level, but sky box still can’t be cliped out.

SceneCaptureComponent2D->General Show Flags->Atmosphere

1 Like

Might be six years since this was posted - by thank you!!! :slight_smile:

1 Like

When I disable atmosphere show flags, it disables atmosphere for the main camera as well? how do i fix this?

1 Like

If you want the background to be transparent, you also need to hook 1 minus A from the TextureSample into Opacity in your material, and set BlendMode on the material to Translucent (you could also use Masked, but then the borders are distorted)