Download

how to have beautiful shadows?

hello,

I try to have beautiful shadows outside …

except that I have not a terrible outcome … the wavy shadows or are just ugly.
Or the texture is super clear …

arriere.png

fqsd.png

what to do? plz !

thank you for your answers

sorry for my bad english

up your lightmap resolution if you’re baking, else it’s just that your mesh is not dense enough

ok tanks I’m going to try

Worse and worse …
it was easier on UE3

http://img15.hostingpics.net/pics/223859jkhihik.png

anyone? :frowning:

Add lightmass importance volumes and make sure you’re baling your lightmaps at production quality.

i have lightmass importance volumes … and i make with production quality… and the result is the same.

look, i use a basic material for test :
54b2cff5dcafcaf4b16b2f4af80441936ec78056.png

the result:
http://img11.hostingpics.net/pics/879792screen1b.png

Now, I use the material I have built for this landscape

http://img11.hostingpics.net/pics/496326screen2a.png

the result :
http://img11.hostingpics.net/pics/677756screen2b.png

It looks like some kind of specularity error… Since UE4 uses an PBR material approach, your problem is perhaps caused by the wrong setup in the material editor. I wouldn´t use the specular slot, try using roughness with a value of 0.8 and plug a metal node value of 0 into it.

Not 100% sure if that´s causing your issues, but you could give it a try.

thank you for your reply, I tried, it did not yield any change. …

I managed, I do not know how I redo everything from 0 in the same way but this time it worked in.

I have one last question …
I did a day / night cycle and once at night there is no night dark … and more sunlight passes through the landscape … what to do plz ?

The solution to the light issue is just to turn off the light when its night.