Download

How to get the Oculus Lipsync Plugin working in 4.26

Hey Everyone,

Thought I’d have a crack at getting the (excellent) Oculus Lipsync Plugin for UE4 going in 4.26.

Here’s their page for it: https://developer.oculus.com/documentation/unreal/audio-ovrlipsync-unreal/

I’m okish in C++ but no guru, fortunately it turned out to be next to nothing to get it going again (but you do need to know how to meddle in VS and C++).

So you wanna get to this file:

And add this line just after the includes at the top:

And then build, and hey hey, the plugin should work in 4.26 :slight_smile:

1 Like

Now if only there was some sort of new character technology to try it out on…

Thank you @ioFlow! This one looks really interesting… have you used it? Does it work well? Also - would it work for a non-vr project?

https://youtube.com/watch?v=xNYqQauEe7s

Thanks for posting! Worked like a charm!!

Hmm, actually, only the PlaybackBlueprint (OVRLipSyncPlayback) works… the LiveCaptureBlueprint (OVRLipSync) doesn’t… both are still working in my 4.25 build. I thought it might have something to do with the device default, but I set my microphone as the default in windows, and that didn’t help. Also tried changing the name in DEFAULT_DEVICE_NAME but that didn’t help either. Were you able to get it work with live? (the lip syncing seems better in live vs the precomputed, at least in 4.25)

Fixed it by replacing the “Default Device” text with an empty string “” (which forces the default microphone device in 4.26)

Sweet! No I hadn’t tried live, my interests lie in the direction of RPG dialog :slight_smile:

Hey guys,
also got it going in 4.26 thanks to your tips here! However i’m struggeling with getting the live capture working in my own project. So the live capture works in the demo map as expected. However if i migrate the LiveCaptureBlueprint over to my project in order to test it out, the lip sync won’t work. It appears that the OnVisemesReady event is never called after entering play mode. @DenRunner, did you make it work in your own project and if so, did you have to do any additional setup in that project in order to make the live capture work?
Thx for any hints on this!

Oh btw., the playback version of lipsync works in my own project, so it’s just a problem with the live feature.

Think i found it.

In the DefaultEngine.ini of your own project you have to add this (Copy/Paste from DefaultEngine.ini of the Oculus Lipsync demo project)


[Voice]
bEnabled=True

[OnlineSubsystem]
bHasVoiceEnabled=False


And in DefaultGame.ini you have to add this:


[/Script/Engine.GameSession]
bRequiresPushToTalk=false

After doing that the live lipsync feature also works in my own project. So thx again for the hints you gave us and maybe my 5 cents might help someone else too.

Cheers!

Ey guys! Please, Can u explain better how can we build this plugin in 4.26?? Im 3d developer and i dont know c+ programming, but i tried how u said up

`` So you wanna get to this file:

https://forums.unrealengine.com/core/image/gif;base64

And add this line just after the includes at the top:

https://forums.unrealengine.com/core/image/gif;base64
​ ´´

i got this error: [ATTACH=JSON]{“data-align”:“center”,“data-size”:“full”,“data-tempid”:“temp_216753_1616936438812_263”,“title”:“error.png”}[/ATTACH]

https://forums.unrealengine.com/core/image/gif;base64

(sorry for spanish language, ive to change this´´

it said `` cannot open include file : …

Can please help me? Ive a project perfectly running with customs characters and vissement in 4.25 and need next version to improve this :slight_smile:
https://forums.unrealengine.com/core/image/gif;base64

Thanks at all

Hmmm… error pic didn’t come through…

Maybe try posting it again.

Hello, you probably already saw this, but maybe it will help others:

With the OVR files for 4.25 available as of 4/30/2021 the ini fixes are already included so the only fix you need to do is to add the one line to the file:
‘OVRLipSyncLiveActorComponent.cpp’,
(shown below as text w/ surrounding code for clarity):
The actual line you add after the ‘#includes’ is this:

    #define DEFAULT_DEVICE_NAME TEXT("")

Note the double Quotes “” in the brackets! Paste in after '#include ’ like this:

#include “OVRLipSyncLiveActorComponent.h”
#include “AndroidPermissionCallbackProxy.h”
#include “AndroidPermissionFunctionLibrary.h”
#include “OVRLipSyncContextWrapper.h”
#include “Voice/Public/VoiceModule.h”
#include <Core.h>
#include

#define DEFAULT_DEVICE_NAME TEXT("")

// Convert OVRLipSyncProviderKind enum to OVRLipSync
ovrLipSyncContextProvider ContextProviderFromProviderKind(OVRLipSyncProviderKind Kind)
{

Then right click your .uproject file to change versions/generate project files etc. It should open in 4.26 fine now and Live is working great!

 Come check out my upcoming premiere for: 
                    **'WORKING *(while)* IN VR!'**

my UE4 & VR Training Series at: youtube.com/NextWorldVR

I’m ‘Woody’, come join me to learn about using VR to make VR! :slight_smile: (Subscribe for live-premiere announcement)

So, i am trying to install this plugin in UE4.26.2 - yet when i try to run my project it just says that i cannot compile modules at runtime and to build in an IDE - not sure what to do. Any help?

where is the file, I can’ see it ?

Looks like your original post is missing data. Probably occurred when the forum was upgraded. Can you update the initial post for posterity?