Download

How to get Soft Shadows without ....

How to get soft shadows without ray- tracing when using a MOVEABLE Light?

So far I changed the Source Radius (increase to 50) in the hope the shadow would get softer.
But nothing. The Shadow always stays sharp.

Light Source:
Point Light–>Moveable

@use-case:
Should work for VR (PC).

What am I missing here?
Thanks for any little help,
appreciate it!

Turn on distance field shadows on your light and then adjust the source radius

or use a stationary/static light and bake the shadows

For a movable point light, I’m not sure, but for directional having soft shadows can get screwed up by cascading shadow maps if they’re not set a certain way. For instance, the exponent setting for CSM could be too low or too high, distributing the soft shadows out of rendering, it seems, replacing them with sharp shadows. A point light also requires the attenuation radius to be adjusted to soften shadows.

Thanks for your reply everyone.

@Arkiras
Distance Field Shadows don’t do the trick, because I want a MOVEABLE Light source.
Distance Field Shadows works only for static geometry and non-moveable objects.

I know the posted image doesn’t show a moving object like a character.
But that’s basically the problem. I want a moveable light that casts a soft shadow.

@presto423
yes, I checked all the different shadow values. no way to get the shadow soft.
again, it’s non ray-traced.

Did you actually try it?