How to get Metahuman looking right on M1 Max Macbook?

I’ve experienced many issues with metahumans not appearing right in Unreal Engine on my Mac, and I really want to figure this out. Often times hair doesn’t appear no matter what settings I use, and same for beards. Overall, they look so much different than they do in the metahuman creator. I’ve searched every topic on this forum regarding this, and I believe I’ve tried every option in the settings for all the assets. I’ve likely spent 30+ hours troubleshooting metahumans, with the base case scenario for a model being something doable with low quality hair, but with the model still not appearing as it does in metahuman creator. Here’s screenshots as an example of a best case scenario, where they aren’t permanently bald (some models will never have hair, eyelashes, eyebrows, etc regardless of settings):


If someone has a magic solution, that’d be great, but I have a feeling this will be something the developers of Unreal Engine/Metahumans will have to correct. If this can be corrected, it will be a game changer for Mac users!

On MacOS in 5.2 and early, there is NO support for strand Grooms. On MacOS you will be looking at the card based hair, which doesn’t have the same render quality as the Creator App which is running on Windows most likely.

Also in the creator app, if you look there are little warnings when you select a groom/hair that doesn’t have card hair yet. Those grooms will not appear on MacOS.

I imagine that strand grooms will come to MacOS in the future, as UE 5.2 now has a full Universal Binary release.