How to - FULLSCREEN - packaged build?

Dear community,
I must be overlooking something simple here.

I would like to be able to run packaged projects in full screen - the way the editor viewport would when f11 is pressed for “Immersive Mode”

What I seem to be getting is the windowed mode on launch and after pressing alt+enter - the build indeed does switch fullscreen but is still letterboxed (black borders on all sides)

I have played around with the ‘New Window Size’ values in Editor Preferences > Play > Play in New Window but that doesn’t seem to change anything…

Would greatly appreciate any tips!
Thank you, kindly.

You need to set fullscreen in config files (if Project Settings does no have UI for it). In Config directory in your project directory you got your default config files, where in “Saved/Config” you got you current config files that editor uses. Configs with “Editor” and “Game” are compatible to eachother, but one is run for editor one is run on game. There should be GameUserSettings.ini with this:

[/Script/Engine.GameUserSettings]
bUseVSync=False
ResolutionSizeX=1280
ResolutionSizeY=1024
LastUserConfirmedResolutionSizeX=1280
LastUserConfirmedResolutionSizeY=1024
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=False
FullscreenMode=2
LastConfirmedFullscreenMode=2
Version=5

As you can see you got screen settings here :slight_smile: set as you like and copy this file as DefaultGameUserSettings.ini in to Config directory and now this config gonna be used as game default config and when player will first run the game this config gonna be copied to Saved/Config as everything else in Config.

Update: People seems to not understand, so i say it again, you need to paste that in defaults in Config directory, not Saved/Config, you use Saved/Config just as example how to set up defults in Config directory. So you place code above inside DefaultGameUserSettings.ini and place it in Config directory (NOT in Saved/Config)

1 Like

Understood!

I can’t get this to work, It keeps overriding the settings back to the original. Any advice?

Perhaps you need to edit it whilst the game is off? I seem to remember that in UDK the software would overwrite config files when you shutdown…

The default setting getting overwrited?

this problably isnt the best way but i couldnt get that ini to not get blanked out even if i did it when my editor was closed. if i continue down this path I will create a save game object with all of these settings and have it react based on that on load

What INIs did you edited and where? for me this blanking is something that should not happen, you should be able to freely edit those default INIs

As i said you need to keep in defults, inside defults, in Config/ directory and you create DefaultGameUserSettings.ini and place stuff there

projectname\Saved\Config\CleanSourceConfigs\GameUserSettings.ini

probably the wrong one - i didnt try the ini route for too long - i dont mind doing it in blueprint/ui/savegames

If you don’t want to use ini you can also hardcode it in your GameMode class, just override BeginPlay() and implement it like that:

void AMyGameMode::BeginPlay()
{
	// ... your code ...
	
	if(GEngine)
	{
		UGameUserSettings* MyGameSettings = GEngine->GetGameUserSettings();
		MyGameSettings->SetScreenResolution(FIntPoint(1024,768));
		MyGameSettings->SetFullscreenMode(EWindowMode::Fullscreen);
		MyGameSettings->SetVSyncEnabled(true);
		MyGameSettings->ApplySettings();
	}
	
	// ... your code ...
}

cool thanks, just posting an alternative solution

Actually, for fullscreen, the FullscreenMode has to be 0, not 2. Also, If you don’t want to use fixed resolution bUseDesktopResolutionForFullscreen should equal True

1 Like

I just copy pasted my current setting as example, i assumed he will figure how to set up things

Depending on your browser, if you Select/Copy the config file lines posted by Shadowriver above, you may encounter blank spaces at the beginning of each line. When you paste those into your text editor, you may not realize that your lines all start with a space. YOU MUST REMOVE LEADING SPACES!

The .ini file parser used in Unreal is apparently either intolerant or pedantic of leading space characters on the left (key) side of .ini file lines, so this will cause your .ini file entries to have no effect.

Note to Unreal’s forum moderators: could you perhaps implement a little “Copy to Clipboard” button that appears above and below any blocks of code posted on the Unreal forums? It would alleviate the above problem. :slight_smile:

After building packages, there is no “saved” folder. But after playing game once, there is $EXPORT_FOLDER%\WindowsNoEditor$GAME_NAME$\Saved\Config\WindowsNoEditor folder. Content of this GameUserSettings.ini file in this folder is normally empty.

Paste these all settings on that empty GameUserSettings.ini file (without line number). Then save it.

  1. [/Script/Engine.GameUserSettings]
  2. bUseVSync=False
  3. ResolutionSizeX=1600
  4. ResolutionSizeY=900
  5. LastUserConfirmedResolutionSizeX=1600
  6. LastUserConfirmedResolutionSizeY=900
  7. WindowPosX=-1
  8. WindowPosY=-1
  9. bUseDesktopResolutionForFullscreen=False
  10. FullscreenMode=0
  11. LastConfirmedFullscreenMode=0
  12. Version=5

Don’t forget it, FullscreenMode=0.
The trial game would be run in fullscreen mode.

Note: These settings could be also automatically generated while using blueprint/code to manipulate fullscreen mode in runtime by pressing a custom key made by user.

Hi I am very new to this and interested in learning to create something possibly. I tried running the game and i got a horrible resolution im using a GTX970 nvidia so I know its not the card. Anyways you said put the "create an ini "? into a defaults directory, but that doesnt exist in the build I downloaded. So do i goto my directory which is Libaries\Documents\saved is the only place i see a folder called config is this where i create a folder called defaults and make an ini in notepad with the name you provided and then paste the info from your post??

Hi does anyone know why Version=5 is added?

It would be great to have the default resolution settings for the packaged game available in the Project settings in the editor.

I was surprised that the Editor settings for “Play in Standalone Game” didn’t carry over to the packaged game.

Even the “play in stand alone game” section doesn’t have a fullscreen option. I had to add “-fullscreen” in Additional launch parameters to get the game to be fullscreen there.

UE4.8:

Confirmed that adding a DefaultGameUserSettings.ini file to the Config folder (ala Shadowriver’s response) will allow you to start deployed exes in fullscreen.

I used the following (make sure there are no whitespaces at the beginning of each line if copying):

[/Script/Engine.GameUserSettings]
bUseVSync=True
WindowPosX=-1
WindowPosY=-1
bUseDesktopResolutionForFullscreen=True
FullscreenMode=0
LastConfirmedFullscreenMode=0
Version=5

I removed the ResolutionSize and LastUserConfirmedResolutionSize lines because they were causing a default resolution different from my monitor, stretching the image. Also, FullscreenMode needs to be 0.

DefaultGameUserSettings.ini is copied automatically when deploying, so fullscreen works correctly by default when running the executable that is generated in Saved\StagedBuilds