How to - FULLSCREEN - packaged build?

Hi, for Mac once the standalone binary starts a user can press Alt-Enter to go into fullscreen. Of course, automatically starting in fullscreen would be nice as per instructions above, etc.

I don’t get it. My deployed application has no Saved/Config folder at all. This is very hard to follow.

Let me try to explain.

Before you deploy, in your project directory, there should be folders Build, Config, Content, Intermediate, Saved, etc.

In the Config folder there are files like DefaultEditor.ini, DefaultEngine.ini, etc. Note that there isn’t a DefaultGameUserSettings.ini file by default. You can make it yourself and fill in the contents as I posted above. An ini file is just a text file so if you create a text file and save it as DefaultGameUserSettings.ini there will be no problem.

When deploying, the contents of this Config folder are copied over to project\Saved\Config\Windows. This is the folder that is referred to for config files when executing the exe file generated from deployment (the exe is in project\Saved\StagedBuilds\WindowsNoEditor). As a side-note, deployment is different from packaging, in which case everything appears to be getting packed into a .pak file. The contents of the config file appear to be getting built into the pak file so there’s no problem.

But this post is still one of the best matches where I get searching today for full screen by default with desktop resolution. I think it’s extremely weird this basic thing that absolutely everybody that uses the engine would want to change is still so buried. There must be a reason to default a small res window like the year is 2000, but still very hard to imagine why make it so difficult and hidden how to display our contend within mere HD standards. Specially those of us who use only blueprints and the editor.

Not to mention the possibility to change quality settings. I did it all months ago on 4.3 with those hacky string concats and console commands but forgot the workflow (that changed anyway and already on 4.4 I couldn’t get it working).
http://puu.sh/k9EuE/2194fb831b.png
I see what my past self did and can’t find every change I should copy, specially with oculusVR. Guess this project I will output only on video due to time constrains. Shame.


Also, the contentExamples don’t work on VR.

lol-- in all the questions i’m seeking answers to, Sean Gribbin from the Unreal staff shows up and announces the thread is closed and fails to provide any sort of answer.

Why in god’s name isn’t there a simple check box in package settings to make your app launch full screen??? If making your app launch full screen is this complicated and has this many people scratching their heads there is a PROBLEM unreal.

Yes. If you look in “GameUserSettings.cpp”, there is an enum which contains the current version number for these settings:

enum EGameUserSettingsVersion

{

/** Version for user game settings. All settings will be wiped if the serialized version differs. */

UE_GAMEUSERSETTINGS_VERSION = 5

};

As it suggests, the settings will only be active if the version number between the settings file and the engine match.

Here’s what I did:
Open Level Blueprint
Right Click and Type/Select “EVENT BEGIN PLAY”
Right Click and Type/Select “Execute Console Command”
In the Text Space Next to Command, Type “FULLSCREEN”
Connect the Event Begin Play and the Execute Console Command Boxes (Connecting the two white triangle boxes)

SOLVED! Add the command “-fullscreen” to “additional Launch Parameters”!!!

Unfortunately this doesn’t work for packaged games, only in editor standalone

You’d think such a thing wouldn’t be so cryptic…I feel like Link lol :smiley:

Because various answers in this thread will work, I am closing this post because, as Kensei has pointed out, it is becoming rather cryptic and confusing to follow.

If you are still experiencing a problem having your packaged project start in full screen on it’s intended device after UE 4.12.5, please create a new post for an up to date and more concise answer. -Thanks!