Download

How to fix depth sort "popping" issues on Niagara particles?

Hi

I’m working with a Niagara emitter / system with a set of hand drawn cloud textures for particles. I am noticing that whenever two sprite shapes move past one another and exchange depth sort order, the particles appear to suddenly “pop” on the given frame. I am wondering how I can eliminate this popping so that the animation on the cloud looks smoother and more appealing.

In short, how do y’all manage to get smooth, appealing and pop-free particle systems?

The undesired popping effect on the clouds can be seen in this video.

Here is my material for the clouds.

And here are the Niagara render settings.

Ideally I would like to smooth out the pop so that either A) it doesn’t happen at all, or B) it happens gradually over a larger span of frames. I’ve considered a few solutions but I am not quite sure at the moment how to implement them.

  1. Cross-fade instead of a sudden cut.
  2. Force the depth sort of newer particles to be on top of older ones.
  3. Constrain the particle movement so that the particles don’t ever cross depths.
  4. Adjust transparency or opacity settings, or use other material expressions.
  5. Other Niagara render settings?

Thank you!