How to enable two-sided water with a blueprint?

I am using the water samples from the launcher.

I found the “Use Two-Sided Lighting” option, but it is greyed out. A prompt above says that I can only edit the water within a blueprint.

How to I enable this flag from the blueprint?

PS: A diplomatic/cultural question on UE Forums-- can I repost my question if it goes unanswered for a day?

You can open the BP and edit select the watersurface mesh in the components tab and changing the mobility to Static (default is movable). This will enable the check box in the details panel on the right side. Be aware that this setting is only for lightmass with baked lighting and not for movable dynamic lighting.

It’s acceptable to bump your question if after a day it has fallen from the first page. However, it’s not recommended to post a duplicate question. These will be deleted or closed and point to the original post depending on the situation.

Thanks. I was able to check the two-sided box now, but I still cant see the water surface when underwater. What else could be going on?

The material needs to be set to two-sided as well, not the lighting or the mesh. This will not work with the translucent water material though since that has a custom depth buffer on it. The lake and the ocean material ones will work OK with the two-sided method.


LONG ANSWER: Where EXACTLY in this maze of menus and tabs will I find a two-sided material option? I have looked at everything I can imagine, and can’t see any materials with two-sided options. (and google can only find the two-sided lighting option)

In the World Outliner, I have a BP_LakeWater. The BP_Lakewater has details panel, but nothing there looks like a two-sided option. I click on the “Edit Blueprint” button on the BP_LakeWater details, and I get a new tab that shows the water blueprint, a Components TAB, and another Details tab.

The Components Tab has two items BP_Lakewater(self) and a sub-component called WaterSurface. Clicking on each one bring up different values in the Details Tab. Lots of stuff to read! Nothing about two-sided materials found.

So next I explore the Content Browser and try editing the M_LakeWater_01_Inst. It does not have a two-sided option. There is also a M_LakeWater_01 material, so I try editing that. In its Details tab, under Materials, there is a Two-Sided box. I check it and then go back to my project tab and press PLAY. Nothing! The water looks fine from above, but from below there is nothing there.

I stop the editor and go back to the M_LakeWater_01 material tab and close it. Now it asks if I want to APPLY the changes I made. Of course I do! Why did it not ask when I clicked play? or when I left the tab? Why not give me an APPLY button on the material? Oh Well…

Once it applied the change that I made I pressed PLAY, and IT WORKS!!!

Lesson learned? maybe… Now don’t get me wrong, I have been playing Eve for two years, so I am not afraid of the learning curve, but… how was a newbie really supposed to find this? I welcome a feature-rich UI, but how to find something new? Go tweak X? Do you mean A/B/C.D/E/F/X? You have answered a single question, but I am afraid I have not learned how to learn. I have tried googling “Two Sided” in the context of Unreal Engine, and did not find this checkbox. I found the lighting one instead. Is there a searchable list of ALL the tabs and parameters somewhere?

TL;DR: can the UI be made easier to search or discover without removing its power? Once I know where all these power tools are stored it will be great! In the mean time, this forum has fixed every problem I ran into… THANKS!!

You have to open the material then select the bar with all the material inputs. The details panel on the left will have an option for two sides.