Download

How to enable the Normal output in a Unlit, Translucent, Surface Material.

Hello all!

I’m trying to create a heat distortion effect for a VFX study I’m doing. I want to do this by recreating the Heat Distortion material that is used in the P_fire asset of the Starter Content.

However, when I open my newly created material, I am unable to set all the material options as they are in the example without losing access to my normal output (which I need to run my distortion normal map through!).

I’ve wracked my brain for every bit of Unreal knowledge I can muster, and have done my best to find a solution posted, but I’m at a loss. In the attached picture, I have the example material above, and my new material below. I’ve matched all the settings in the Detail panel which hasn’t helped, and I’m not sure where else I should be looking. Hopefully you guys can shed some light on the situation!



Thanks so much!

I recreated the heat distortion material from the starter folder that’s in the folder containing P_fire, and discovered what enables the normal pin on the main material node. It’s the dynamic parameter and lerp at the bottom of the setup. There’s also a setting to enable under the details panel list for the material (select Main Material Node to see details panel of the new material). It’s called “Fully Rough”. It’s disabled by default in a new material, as far as I encountered.

linded refraction pin a vaule :grin: