How to enable RTTI?

I need RTTI. How can i enable it?
bUseRTTI seems obsolete.

I have the same need, and there are some unpleasant workarounds if it no longer works…I can’t seem to get a response on this from Unreal or elsewhere, nor can you really find current support on this when searching. While one may need it to integrate with C++ libraries/DLLs that leverage RTTI (in my case, it is mathematical and robotics/control libraries), we’re in a minority. I get the sense that they just don’t want this used.

I believe bRTTI did work at one point in 4.8. And it may still be enabled: I recall enabling that and seeing -GR inside the generated .obj files unreal creates (.obj files for MSVC have text regions where you can see all the command line options used, there are ansi text regions mixed with the binary, search for “cl.exe” and you will find it.). In 4.9, however, I no longer see the -GR options on the individual .cpp components…however, I do see a -GR on the precompiled header. So maybe it is working…I am not certain. Play with the feature and read your .obj files and see if the GR comes and goes. If not:

I think there are two possible solutions, neither great. Haven’t implemented because I abstracted the RTTI interfaces for the time being. But I believe they are: 1) get to know and modify the unreal csharp build system. I have looked at the source and one can certainly add whatever extensions one likes to it. 2) create a shim for your compiler (in MSFT case, cl.exe) such that the shim will pass through all the compilation options given it to the real compiler, but can also add additional ones. In this way, you can add the /GR+ switch that enabled RTTI.

I can confirm that bUseRTTI actually is working. You have to place it in %(ProjectName).Build.cs file.