Download

How to enable Chaos

Hi, I failed to open Chaos Demo in 4.23, and now I tried to build with 4.25 but I’m afraid to fail cause I can’t download source code even I’ve connected my account to epic.

Can anybody download source code from github??? Why I can’t do this? the page shows 404

so Can you help me to download some additional files to open chaos? I’d like it to work on 4.23 version at least

I have down loaded it and the compiled version 4.25 is great. https://www.youtube.com/watch?v=1lfSFlMEwbE&t=2s

I figured it out, you have to follow the guide in the OP, not in the documentation.

Important points not present in the documentation page:

I did manage to finally compile the engine from release branch and launch the project. But now it looks like the fields are completely ignored in all example maps. Can anyone confirm that fields are working for them? Additionally engine version for the project is 4.24 some why, even though I compiled 4.25 from release brunch

I’ve also been unable to get Chaos to work with 4.25. I also get the error message that @Terrian get and have been unable to fix it. It feels like a rather small issue since it’s something that’s declared twice, but haven’t been able to find where it’s declared at all thus far…

Has anyone tried with the 4.25 Plus branch to see if that works?

Watch this video https://www.youtube.com/watch?v=1lfSFlMEwbE Look at the comments. I did it with 4.25 source. In 4.25 Chaos is faster and easier to use.

Hello I have tried several time to build and use chaos on 4.25 release build but no matter what I try it always fails I have added both bCompileChaos = true; bUseChaos = true; and also change .shared to .unique and have tried to follow https://www.youtube.com/watch?v=1lfSFlMEwbE comments to no avail but it still does not launch after building the engine I get the Shader type was loaded after engine init, use ELoadingPhase::PostConfigInit on your module to cause it to load earlier. error how do I fix it. Thanks

I commented out that line and rebuilt (points it out when fails), works OK for me.

I not getting this error now im getting this NightmareEditor modifies the value of bCompileChaos. This is not allowed, as NightmareEditor has build products in common with UE4Editor. and I created it with the built engine

I haven’t tried yet but I’m guessing maybe the ChaosDestructionDemo is necessary for it to compile properly? I tried to compile UE 4.25 but without the demo as I figured I just wanted to play around myself.

That’s the only thing I can think of since, built UE4 from source before just fine so it’s certainly something with Chaos. :confused:

Try this link https://www.youtube.com/watch?v=1lfSFlMEwbE&t=4s This is right at the end of the video. It is a compiled version 4.25.

Does someone know if it is possible to filter chunks based on their volume/weight, and delete them instead of spawning them when applying strain on a destructible mesh?

I don’t want to have 100 small chunks spawning, rolling around and reducing performances when I can simply replace them with Niagara and only keep the large ones…

I’m still new to the system but would adjusting the “max cluster level” on the geometry cache get you what you want? I believe its intent is to help stop meshes from breaking to the smallest pieces that have been fractured/clustered. It isn’t exactly the technique you are asking about but might provide the control you are after?

General perf question for everyone. There seems to be a perf gap since the 4.23 release of chaos, at least within the test levels. On the order of 10-12ms increase for the same content. And in some instances what had been running smoothly in 4.23 (the scripted destruction of the building in the “Geometry_Collections” level) can dip way down into the red, teens and single digits in 4.24 and 4.25.

I’m assuming this is true for everyone else and not something specific to my build(s). Is that correct?

No, this is not the control I am looking for.
I WANT to fracture very small pieces, however because of their small size they have cannot hurt players when hitting them, or provide cover. These small pieces are literally useless once removed from their original spot, which is why I want to delete them instantly.
You just have to spawn some dust FX to hide this trick.

This trick is described here : https://www.gdcvault.com/play/102330…Destruction-in
and here : https://www.gdcvault.com/play/102300…Destruction-in

I didn’t manage to get the demo running in 4.23 but I tried it in 4.25 and yeah, the performances are terribly bad. In 4.23 I remember the destruction was lagging a lot but not the framerate because the destruction was happening in a separated thread, however in 4.25 it seems the destruction impacts the frame rate… I reached 5-10 FPS when running through a showroom to activate all triggers in the same time.

Hello. I was able to compile 4.25 with the template demo following the instructions but when i run the default map, it starts fine but it crashes once it starts simulating (after pressing a button in the map), any pointers?

Did you get your explanation? Because I can’t make it work here… Could you show the different steps please?

Seems like the only possible way through my experiments is to use the variable bOverrideBuildEnvironment in your project EditorTarget cs file.



bCompileChaos = true;
bUseChaos = true;
bOverrideBuildEnvironment = true;


I don’t understand this setting so much really as it basically skips the validation of modules that require a unique build when using a shared build of the engine but it does compile and start the engine at least. I really hope we hear something from some devs here

My 4.25 demo runs if I follow the documentation’s steps. However, if I want to launch it from the UE4Editor.exe I generated, it tells me “this project was built with a different engine, rebuilt now?” and then the rebuild fails.

My ChaosDestructionDemoEditor.Target.cs file contains this :


Type = TargetType.Editor;

ExtraModuleNames.AddRange( new string] { "ChaosDestructionDemo" } );

bCompileChaos = true;
bUseChaos = true;
bCompilePhysX = true;
bCompileAPEX = true;
bCompileNvCloth = true;
bCustomSceneQueryStructure = true;
BuildEnvironment = TargetBuildEnvironment.Unique;

Unreal told me there was a problem with


bUseChaos = true;

and told me to use


BuildEnvironment = TargetBuildEnvironment.Unique;

or


bOverrideBuildEnvironment = true;

but both did not work, I had to remove


bUseChaos = true;

. Now the engine tells me “ChaosDestructionDemo could not be compiled. Try rebuilding from source manually.”…

To resume, I can work with the demo by following the documentation’s steps, but it requires to keep a dedicated engine only for it because there is a problem with this step from the documentation :
6. Build the ChaosDestructionDemo for Development Editor (should be the default Visual Studio configuration). This will build the whole engine, with Chaos, since it’s already setup in the project’s Target file.” -> this does not generate an UE4Editor.exe

So I have a 2nd engine I built the “classic” way, with Chaos working great and a generated .exe, but I cannot open the Demo with this one… Really weird.