How to effectively avoid repeating texture on landscape?

Hi guys I am new to UE4 landscape editing. When I created a landscape, I found no matter how complicate the textures are, when I apply them to the terrain, there is always a obvious repeating pattern. I did try to increase the U and V tiling in landscape coordinates, but it did not work out too well, I know I could just increase the UV tiling to over 100, it would decrease the repeating patterns but it will also ruin the quality of my texture. I tried to layer paint on the terrain, even though there is still tiling pattern.
I looked into the starter content to see how those default texture are edited in blueprints. It is better at avoiding repeating patterns when I applied it to mine assets, but then I could not do layer paint anymore.
Is there anyway to avoid this problem?
Here are some screenshots, the blueprints are two different ways I tried, unfortunately I still can’t fix the issue.

Sorry was on my phone couldnt see the pics, so your blending, now just change your mapping scale in the landscape coords to match the landscape resolution. You can go into where you created the landscape to see what that resolution is.

I would look at blending multiple textures I used three normally and wire that into a splat map this will take the repeating pattern out as your blending between 3 textures in different spots with the splat map. Also make sure when you’re plugging your texture in to the landscape coordinates its resolution is the same as landscape. Normally the resolution of the landscape is a number like 2142 which will seem like a odd number. Scale your texture to that number.

.

Thank you! But I couldnt find my landscape size, can you tell me more details of where to see the size? Sorry I’m at beginner level in UE4, I dont a lot of stuffs.

Hello Alt wang, try this as well:

This setup will blend the regular (close up) version of your texture with an upscaled version depending on distance.
this significantly reduced texture-repeating!

Just put the output of the clamp into a lerp:

There are multiple ways of doing it, in my case I made it a parameter for material instances, you could just directly imput the texture coordinate nodes into the texture-uv input and scale it up trough the texture coordinate node.

Go into landscape components it is the landscape component size

Its been awhile since I have done landscapes when I get home I’ll take a look to see exactly where it is if you haven’t found it by then

Ok if you go back into where you created your landscape where it says overall resolution plug that number in

I found my landscape resolution is 121x121, I put that number into the landscape coordinate, it doesn’t work, the texture is extremely stretched to fit the terrain, it’s so blurred.

if your texture is 2048, try inputing that number

No man, it will get even more stretched. I think using the splat map is probably the right way to do it. Do you know how create splat maps?

Thank you Luos! Im trying your way now, so for the textures, are you still using landscapecoords to control them? Also do I put the output of Lerp in to the layer blend or basic color?

Try to input it into the layer blend.

@Luos: thanks very much, this is a super efficient method of removing tiling.

@Luos sorry to bring this back from so many years ago, but how would I go about adding 3 or more blend distances to this?