Download

How to disable shadows?

Hi! I’m making a game with blocky graphics, so i want have an uniform lighting and no shadows, just ambient occlusion, but i don’t know how to achieve that. I’m trying to do so for two day, but there’s some weird problems appearing.
5f2b9c68eca931902938717f288336b670e8f7f5.jpeg
Any idea on how to fix that?

Ps: Sorry if i said something wrong, it’s not my main language.

Select Light Source and in properties uncheck cast shadow, you might also try disabling precomputed lighting in light mass settings, those dark lines look like light map artifacts

Thank you! I unchecked “cast shadow” from the Skylight and it worked like a charm.

Is there a way to disable shadows for some materials or mesh? I am using procedural grass and I want to disable shadows just for the grass, not anything else like trees/houses/etc. Hoping I dont have to use a sledgehammer approach to shadow casting. Shadow on procedural grass is killing performance.

You can open your static mesh and disable “cast shadow” beneath the material slots of each LOD.

Ya figured that out - now the issue is there are 110 grass models in the package that I am using. Maybe can be done in C++ at runtime for some group of mesh.

should be able to right click on the grass mesh and hit “select” , then maybe all matching or all grass models , and uncheck cast shadow, and it would remove the shadows for all.