Download

How to disable Lightmass mipmaps

Hello,

i am having this problem with some large lightmaps. I think it is related to mip. When i am closer lightmap seems to be smooth, but at some distance i get this kind of compression banding… any ideas? I have already built at top quality settings, lightmap resolution, is hight, compression is disabled.


i have disabled mip gen setting in the lightmap (lucky i found it), to no mip maps. and now it look ok.

Question: Is there a way to force all lightmaps to nomipmap?

Nothing? I think for video production it would be very usefull…

I have the same problem in a project. I’ll disable the mip gen settings and see if it works. Otherwise, I don’t know if there’s a way to disable mips for all lightmaps. It could be a cvar in the console, or it could require setting no mip maps in every lightmap that’s generated. I’ll look for something and post it if I find it.

Lightmaps have a texture group so in theory you should be able to edit it to change the mipgen settings to no mip maps. In practice, I don’t know that this will actually work, reason being is that it seems lightmass sets all the lightmap textures to “use existing” (instead of using the texture group settings)

You may be able to automate it with python so that you can just run a script and have it change all the lightmap settings on build