How to create network session in packaged game?

I do a network game with blueprint. In the editor I can create a session in my menu and connect to it through another viewport. But when I package game, it doesn’t work anymore. Session becomes to fail every time.
To make this system work I add to the engine’s config files this:

But when I add this strings to the config files of the packaged game (I tried every file) this is seem to not work. How can I create network session in the packaged game?

what problems are you getting in the packaged game? are there any errors? can you use breakpoints to narrow down where the problem is

Any problems? Excuse me? I’ve said that when I create a session it becomes to fail. Just after executing “Create session” the program goes to the branch “On failure” and I receive string “Failed”.
Clip2Net — screen capture tool for Windows, Android, iPad, Mac, Linux (screenshot downloads wrong)

are you trying to use steam or the null subsystem because what you have put in the config file will stop you from accessing steam in the game

I use null subsystem because I read this topic: 4.6 Preview and Create Session - Multiplayer & Networking - Epic Developer Community Forums
In other case I can’t create a session even in the editor. But in the packaged game this settings don’t work

Is it the truth that anyone can’t launch network session in packaged game??? What the heck? Maybe is there a way to create it through c++ programming? Where can I find information about this way?

I also have this problem. But it happens only on my project packaged. Try multiplayer shootout, there are no problems. They used steam service, I tried to copy these lines, but sadly it didn’t help

I have only this problem on my packaged project too. What the multiplayer shootout that you mentioned?


did you adjust your Build.cs?

PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore", "OnlineSubsystem", "OnlineSubsystemNull", "OnlineSubsystemUtils" });

    PrivateDependencyModuleNames.AddRange(new string[] { "OnlineSubsystem" });

These Modules should be included in your project to work properly, I guess the Editor adds them automatically? :confused:
Just a try though, I’m not exactly sure as well …

Somehow I can’t find this file… What the path to this?

Oh I found)) I just deleted folder “Source” because my project didn’t want to package) And I fixed that issue this way. I’ll try it now

It helped! Now I can create session in packaged game! Thank you!

adding “OnlineSubsystem”, “OnlineSubsystemNull”, “OnlineSubsystemUtils” worked for me, i already had “Networking” but none of those. Thanks