How to correctly configure prerequisites for Steam Deck?

My UE 5.4 project is working great on PC and OSX, but I’m having some wrinkles when deploying my PC build on Steam Deck.

Every single time I run, I get:
“The following component(s) are required to run this program: Microsoft Visual C++ Runtime. Would you like to install them now?”

If I hit yes, then it runs the unreal prereq installer and I get into my game, great.

If I quit and run my game again, I get the same initial popup, and then when I hit “yes” I’m brought to Unreal’s prereq UNinstaller. It uninstalls the prereq…and then my game still opens file.

So it flip flops between installing and uninstalling every other run.

This happens both when deploying with the SteamOS Devkit Client, and when deploying through Steamworks and downloading through the Steam client directly. In Steamworks, I do have the VC++ 2022 redistributable selected.

I am packaging my game with -prereqs (when I don’t, I get the same initial popup but without the option to install now, just an OK button and then the app closes). It also happens when I use a build I just package from the editor with default settings.

Since the game works with the prerequisites uninstalled…seems there is something fishy going on here. Does anyone else see this? Any ideas for what to try?

I wasn’t sure if it was just a problem with my Steam Deck but it’s happening to my teammates as well.

3 Likes

I’m having this exact same issue - have likewise tried with/without prereq’s included in the build, and have the steamworks redistributables included.

Haven’t been able to figure out a solution yet.

2 Likes

Same here, exactly as you described. If I start it again after installing the prerequisite then it will uninstall them and still launch fine.

I didn’t have this issue a couple of weeks ago, not sure if it was 5.4 or a proton update (?) that brought this on but it’s slightly annoying.

2 Likes

I’m having the same issue on 5.4 and I don’t remember it happening on earlier versions of the engine but I might have just been lucky before. Hopefully someone will reply here with the answer.

Just commenting here in case anyone ever comes up with a solution.

I have the exact same problem. This is not an issue when using Unreal Engine 5.3, but started happening when updating to Unreal Engine 5.4.

1 Like