How to 'completely' remove motion blur in Movie Render Queue

Hello, when rendering my first movie from the Movie Render Queue, I noticed that the preview images on it do not have the motion blur but the actual saved PNGs do have it. So, the simple thing I want to achieve is to remove it completely from the saved frames/PNGs as well. Though for some reason I could not find how to do it.

As mentioned on the guide I have to Console commands [below] involved in it, but deleting them didn’t help either.
r.MotionBlurQuality: 4
r.MotionBlurSeparable: 1

In my Post Process actor, Motion Blur which previously was set to 0.5 is now set to 0 too.

In my Cine Camera shutter speed is 300 [tried even higher but simply all went dark and could not fix without adjusting all the lights inside my scene], aperture is 1.8 and all the motion blurs are set to 0. So, I thought the Camera’s shutter settings might help but no luck there either.

At this point I am not sure where can I turn it off completely for the renders from Movie Render Queue.

I am attaching a screenshot where you can see the difference in a winded banners movement. Left is the output PNG, right is a screenie from the Render UI.
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_205411_1603207770422_184”,“title”:“difference.PNG”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

Thanks very much in advance.

1 Like

movie render queue motion blur is different than regular sequencer motion blur
so those console variables may not work, and the post process motion blur i read only affects 4.26 not 4.25
what if shutter angle is 0?

I enabled camera and changed the Shutter Angle to 0 in Movie Render Queue and was almost sure it would work cause it mentioned here as well.
https://docs.unrealengine.com/en-US/PythonAPI/class/MoviePipelineCameraSetting.html
‘A shutter angle of 360 means continuous movement, while a shutter angle of zero means no motion blur.’

Didn’t work, the PNGs still have motion blurred.

Also, seems like lots of people after same cause! https://www.reddit.com/r/unrealengine/comments/96tyia/how_to_remove_anything_resembling_motion_blur/

At this point not even sure where to check, browsed all the the motion blur related topics…

Solution is to disable Camera completely in Movie Render Queue and delete all Motion Blur related console variables.

2 Likes

I have the same issue! Could you please explain a bit more in detail? I didn’t understand how you fixed it…

Hello Adberf, sorry just saw the message. Here is the screenshot of the settings I use, I just disabled Camera on left entirely and was fixed.

If you like you can download the preset here: http://s000.tinyupload.com/index.php…95484491137667
Just place the file in Cinematics > MoviePipeline > Presets and select it to see the settings.

One workaround (tested) is to key all frames in sequencer, change interpolation to “constant”, and then in movie render queue - settings - add “camera” and change shutter timing to “frame open”.

5 Likes

Hey, your method works like a charm, I was wondering if there was a way of keying each frame with a single click, instead of toggling through each frame and keying it?

Just set “Amount” and “Max” under “Motion blur” to ‘0’ in your Post Processing and Camera settings on your level. It works for me. I think they also said it on the stream.

4 Likes

Something else I just discovered that might be catching people trying to disable motion blur: Temporal Anti-Aliasing.

I had disabled everything mentioned in this thread but I was still getting motion blur due to my AA settings. Regardless of your motion blur settings, if Temporal AA is enabled (samples >1) it will try to interpolate the position of your actor when it generates the temporal samples.

This is obviously a bummer, as Temporal AA is great for dealing with RTX noise and noise in general, but given how it actually works (samples over time, averaged) I suspect it’s not going to be usable in any render where you need zero motion blur.

1 Like

I think if you turn off TAA, TS-0 and SS->0
it will clean the noise but not render any motionblur

Hey, did you find a way to keying each frame with a single click?

Hey, sorry to bug you - would you be able to re-post this? Links not active anymore. Thank you!

So following the fixes here I have found 2 things:

Re-creating a camera seems to have fixed the motion blur influences not taking effect. So I suggest trying the suggested camera fixes in this thread first.

If the camera is functioning properly the most effective override I believe is In Camera and Post Process volume: Rendering Features > Motion Blur: Amount = 0, Max = 0

If camera and post process work - you don’t need this but Console Variables:
r.MotionBlurQuality = 0 (max is 4, 0 is a suppression)
r.MotionBlurSeparable = 0 (standard is 1)
Though anyone could argue these I’m not as confident about console commands!

Another thing I have seen mentioned is turning motion blur off in the project settings.
Project settings: Default Settings > Motion Blur [X] True or False
For rendered sequences this setting is easily overridden and essentially useless. Leave true

If you are still getting motion blur then as also suggested in this thread change your AA settings: I settled on:
Spatial Sample Count: 32
Temporal Sample Count: 1

That’s my summary! I hope it helps anyone else stuck on this!

4 Likes

setting motion blur amount and max to 0 in camera fixed blurring for me

This worked great.

My chroma png sequence on a plane was getting blurry… so i turned off cinecamera motion blur and the chroma asset rendered sharp without any overlap frame or ghosting

But then things like FIRE…WATER…SMOKE… rendered all SMEARY and ghosty. Spatial 32 and temporal 1 in the movie rendered ALL perfectly.

But my concern is that AM I LOOSING QUALITY KEEPING TEMPORAL AT 1 ? cos the whole world says to usually keep temporal as 32 for quality rendering. But if change anything other than spatial=32 and temporal=1 then every fluid water/fire/smoke goes all smeary again. Hope iam not loosing render quality with temporal as 1 ??? Or am I compromising on something. ??

1 Like