How to completely get rid of indirect lighting for specific movable objects?

We did some performance profiling (PS4) and realized a lot of performance is lost in “Update Indirect Lighting Cache” (using UE4.3)

One way to reduce the problem might be to reduce the lighting sample density / precision in the ini files, but actually most of our moving objects are projectiles which use an unlit shader. They actually don’t need to be lit by indirect lighting at all nor do they need to indirectly illuminate other objects.

Even if I deactivate all checkmarks under “Lighting” including “Affect Dynamic Indirect Lighting” I can still see interpolation points (r.Cache.DrawInterpolationPoints=1) around them when they move.

Enabling “Light as static” somehow seems to move the center of the interpolation point volume, but its still there.

By using a mesh particle instead of a static mesh it looks like we got rid of the interpolation points and reduce the costs by about half, but there is still this other half that is lost in this function.

What is it doing there? Is it possible to completely get rid of the costs for this function for moveable objects that don’t need to influence nor get influenced by indirect lighting at all?

Hi Sven,

Realizing this is an older question, but the gist here is that you can choose disable the indirect lighting samples by selecting the meshes they will affect and in the lighting option change the drop down next to Indirect Lighting Cache Quality to ILCQ Off. This requires the mesh to be movable though.

Alternatively, if you don’t want the light to cast any Indirect Lighting you can always disable it in the light source by setting the Indirect Lighting Intensity to 0.

For the volume light samples that are placed you do not have to edit these in the ini file. These can be adjusted via the World Settings > Lightmass > Volume Light Sample Placement. Lower values will increase the density of the placement and higher values will decrease the density.

Adjusting “Affect Dynamic Indirect Lighting” only affects LPV and had nothing to do with any static lighting contributions.

Thank you!


Hi Tim -

We have a situation where very bright samples are being created outside of a darkened room despite several attempts at volume tweaking. We have thousands of dynamic objects in this room, and many of them are referencing these bright samples.

Is there a way to force an area to not include any samples whatsoever? For example, a way to completely disable all samples from being generated except inside of LightmassImportanceVolumes or LightmassCharacterIndirectDetailVolumes?