Download

How to completely eliminate ambient light

I have a scene with a mesh in it, with all lights in the scene completely turned off and yet I’m still getting some basic ambient light:

f131ca9607b27670ac889fca56380d12cdf438bb.png

With no lights in the scene, this should be completely black/invisible, and yet there seems to be some ambient light coming from somewhere. How can I completely turn this off?

Is there environment color in lightmass settings? Do you have a skylight, HDR image, or reflection capture actor?

You also have to keep in mind that when you dont have any lights in your scene, you will be still abel to see the objects (so that you can still edit some stuff in the editor) -> but when you play the level, it should be completely dark :slight_smile:

Ah, it was to do with lightmass.

Thanks guys!