Download

How to compile lightmass?

Hello everytime I am trying to build my light, it comes an error called: " Lightning build failed. Swarm failed to kick off. Compile Unreal Lightmass. " Can you help me how I can change this?

Do you build the engine from source? If so, you have to recompile the Lightmass module (as the error suggests).

EDIT:
Open the engine solution in Visual Studio and search for UnrealLightmass, then right click: build.
4404e54a006f39e9df0f00d4a08554b86e9bfe4e.jpeg

2 Likes

I get this same error (doesn’t matter what level I try to build, even the default “blank one” with just a floor.)

I rebuilt Unreal Lightmass a half dozen times now, restarted PC, and nothing seems to work.

I’ve also tried everything in the forum post about steps to fix Swarm not starting.

Do you download your UE4 from the launcher or github ?

Github and built whole source.

I’m running as Debug Editor if that matters.

Ok do you tr to make a new clean intallation maybe ?
And try maybe with Development Editor instead ?

FYI, Development Editor worked.

I was going to try that next, but needed a point where I could waste an hour or so building.

It doesn’t show up when i search for it. I already verified the engine. I got it from the launcher. It did work yesterday and now it doesnt :l

EDIT: A mesh was causing the problem. Reimplementing it helped out :slight_smile:

Bcs of copyright Infringement… GitHub has removed UE4 every links.

No they haven’t?

this worked for me when i had a light build failed to kick off compile light mass error. thank you!

I’m having this same issue and the UnrealLightmass file isn’t showing up in VS2017. Someone wanna give me a hand?

Just for info: Using VS2017 with source built UE4.21.2, found UnrealLightmass module, and building it resolved the error. Thanks!

I build the ue4.24.3 from the github source code with the Development Editor option .I have the same problem and compile the UnrealLightmass.It works.

Hello! Where can I compile UnrealLightmass? I am having the same issue.
Also, I downloaded Unreal from the launcher so I don’t have an .sln file.

I really could use a hand so I’m reposting. I generated .sln files from my project but there is no “UnrealLightmass” in it. Should I delete my Engine and download another one from the source or is there another way?

Follow these steps carefully and run all the setup files:

Once you do that, go to the Solution Explorer window in Visual Studio (I’m using 2019) and search for ‘UnrealLightmass’ It’s inside the Programs folder in the solution. R-click on that and choose “Build…” That should do it for you