How to Change Image Shown on Player Map

Hi everyone,

I’ve been trying to locate where the image for the in-game player map is stored and referenced from in the DevKit without any success. Could anyone point me in the right direction?

Thanks!

It’s under world settings if you want to replace the in game map with an image of your own

Thank you, Braix! I haven’t played with the world settings so I guess its a good time to start.

Thanks again

I’m sorry Braix but I’m not seeing it under the world settings. The only references to maps are for a few texture weaponmap and uimaps but that’s not what I’m trying to change. I’m trying to change the map you open up with ‘M’ and look at in-game: https://i.imgur.com/ictFxEE.jpg

its the second one. weapon map texture filled

Ohhhh, thank you Angrytoilet. And thanks again Briax. That name they chose for it didn’t seem to fit, thought it was a texture mapping for generic weapons but it makes sense now… they mean the map when its held in hand instead of a weapon.

Thanks again, everyone!

No problem. Those are for all the different maps from the spawn one to the one held in your hand.

Well, thanks to you, my survivor couldn’t be happier now!

HAHAHAHAA, this is hilarious… I feel like you are slowly recreating the child hood of an island middle school kid.

That is truly epic

Hmmm… I have the pics attached to the proper spot on my mod blueprint, but after I bake, upload, and load in-game we’re back to the plain ol’ map. I’ve verified in the cooked mod folder that the new map pics are there, they are just aren’t writing over the vanilla map. Am I going to have to do this as a map extension for them to properly show in-game? What else am I missing?

Move that map file to …\Mods\YOUR MOD FOLDER\Assets (create the assets folder if you need to)
In the editor, make sure its looking for the picture in that folder.

Remember:
Anything outside of the Primal (with a couple exceptions) and the Mod folder will not get cooked and sent to the server.
Basically, if it doesnt come with the game, pop it into ASSETS folder in your own directory.

Does the folder its in need to be specifically named “Assets”?

My map files are in …/Mods/MY MOD FOLDER/Textures

As stated above, they did get cooked and they are on the server. They just aren’t showing in game; the normal map is still showing. I even tried the mod in both the last and first position, and everything else in the mod is working except for the map switch.

When you set it in the world settings did oyu have your level file open or the “testMap” level open? make sure you open the level file in your mod folder and set it there.

I had it set in world settings of the proper mod file. I double checked it before posting anything but rechecked it after you asked, just in case.

I’m sure its something easy to fix and a rookie mistake. I’ve only been modding the unreal engine for about 2 weeks now so I’m sure I’ll be making plently!

So talking to someone online and it looks like I’ll have to do this one as a map extension rather than a regular mod for the map to show in-game. Thank you all for helping steer me in the right direction! I always appreciate how great the community is.

? nooooooooo… just put it in your mods “assets” folder (the image). Make sure wold settings are looking for it in that directory … cook … upload … win!

Agreed that that’s exactly what should work, and exactly what I did even before posting about this additional problem, only its not working in-game. And I know the assets are there because I see them in the cooked mod’s (the version I downloaded from the workshop) textures folder, right where they should be. If they weren’t referenced, wouldn’t they get left out of the cook?

Would a change like this require the mod to be in a specific part of the load order? I tried the mod in the first and last slots without a win, but I have yet to try it by itself.

just double check the map reference in world settings.
I have my own map working, i mean, its no different then what you have (essentially)

If its in your assets, it doesnt’ matter if its used or not, its getting cooked.