Download

How to change dynamically Niagara float parameter?

Hello !
I’m making thrusters for spaceships and want to change size of that thrusters dynamically when player uses joystick. I want to smoothly change size of the thruster mesh (based on joystick axis value)
here is some screenshots I’ve tried, but not working :confused:

Hi, I think you don’t have to type “user” on the blueprint node. Ex your var is called “length” in the niagara emitter so you just type “length” on the node.
Prefixes are more to sort things inside of the emitter, they are not part of the name.
For example prefix “User” means it is a parameter that you have created

I think Grot may be correct here, but also I notice, I always use the node

image

1 Like

Hey thank you for answer. Without User. prefix it wont work, tested it dozens time

Hey thanks for answer, Still not working

Try updating to 4.27.

You have “length” for X but 0 on other axes, maybe try with 1 on Y and/or Z

Yeah I noticed and changed but no luck :frowning:

I cant :confused: it must be done using 4.26

I have replicated the problem. ( IE, repeated it, not made it into a multiplayer game… :wink: )

Ah, nope, sorry, it works. A ( dumb ) update like this works for me:

If you can pack just this into a tiny project I’ll take a look if you like… I don’t know if it’s a 4.26 thing.

Please clarify the problem, the set parameter function doesn’t work or what.

Yeah this works but want to increase size of the mesh based on joystick input, that’s the problem. smooth resize is not working

set parameter works, but cant change value smoothly using joystick input

Well, found solution, it was problem inside the niagara system, I was setting length variable before
particle update, inside the initialize particle. Removed it and it works !
Thank you everyone !

2 Likes