How to bring in glass texture painted in Substance Painter to UE4

I know that this might sound like a silly question, but if I used Substance Painter to make a glass material in that program with something like blood, dirt, etc on it and then bring it into Unreal I can’t ever get it to work right where it looks like glass. For some reason it turns out looking like metal. I’ve searched around on how to properly bring the textures into Unreal, but I still don’t have a clue on how to bring the material in so that it looks right. Any suggestions? Thanks in advance

First of all, make sure you have “Opacity” channel enabled in Substance Painter. Change the shader to alpha/blend in Substance Painter so you may see what you’re tweaking. Play with the opacity on the Glass layer and the layer with blood/dirt. Then export with Unreal Engine 4 preset. The alpha would be in the A channel of the diffuse. I don’t know which version of SP you’re using, but I came up with a problem in the early versions where alpha wouldn’t export. So instead, I exported it twice - Unreal Engine 4 preset and the default preset With Alpha (I deleted all the textures from the default except the opacity and placed the opacity in the material editor). Something like this: Diffuse / Normal / RoughMetallicAO and Opacity (4 textures in material editor). From here on, it’s straightforward. Just place the Opacity node in Opacity and see if it works :slight_smile:

Thank you so much for the response! That worked perfectly so thank you very much!

hi im having this same issue, i wanted to ask how do i apply the opacity texture to the material when the opacity is blacked out, i’ve tried changing the blend mode of the material to the other options but it comes out looking weird, thanks.

What texture format is needed to get an Alpha Channel in the Diffuse texture?