How Reflections capture are working ?? (translucent ocean material)

Hi, i really need help because i can’t debug my problem…
I have a scene with a house and an ocean.
The problem is the ocean use a particular sphere reflection capture (actually inside the house) for reflection, that mean it is totally false and hugly…
I putted a sphere on the top of the ocean, it work great when all other capture are disabled but when all captures are active it doen’t work.
I can’t figure how to set the capture priorities, i tried to delete all captures and just keep the ocean one (thought priorities was done by ID creation) and recreate the inside ones, it work until i move the ocean capture again.

Is there a way to fix that ? i have the same problem with the swimming pool then i guess its because the material is translucent.
Hope its clear :slight_smile:

i am the only one with this issue ?:confused:

Have you tried setting the capture range for your spheres? Iiirc it’s usually recommended to have one with a big range (like the default 3000) and put several smaller ones in strategic places, with ranges like 300 or so. Put them so they are close to overlapping. You can see the range of the spheres in edit mode.


i know what you mean but it don’t work at all, its look like the translucency shader only take in account 1 reflection sphere, randomly

hi fabilabo, translucent materials use reflection captures in different way than regular opaque materials i had the same problem basically the closest capture to object pivot is used. if you need your ocean object to move and use multiple captures there is no way to smoothly interpolate between them. You might want to use cube map to get single good reflection source for that set specularity of your shader and use emmisive to fake reflection. you can affect reflection of certain water region by lerp-ing multiple cube maps inside shader.

and here is my translucent water you can take look at