How include header in angle breckets, not as "header.h"


Is it possible add include path for *.h files became accessible by:

#include &ltheader.h>

I have expirience with including SQLite as thirdparty. But even after adding to Build.cs:

PublicIncludePaths.Add(Path.Combine(ThirdPartyPath, “sqlite3”, “include”));

it was accessible only by:

#include “…/…/ThirdParty/sqlite3/include/sqlite3.h”

not by:

#include &ltsqlite3.h>
#include “sqlite3.h”


This is my understanding of declaring Includes in C++.

using “sqlite3.h” requires that the .h file is next to the .cpp file that is asking for it. By this i mean both .cpp and .h should be in the same directory together. You probably dont want this because it may clutter your workspace unnecessarily .

using < sqlite3.h > requires that you add the header path to the includes Directory in your project settings/properties. The IDE will look here along with all other header locations for your file named sqlite3.h

Rightclick on the project → Properties → Configuration Properties → VC++ Directories → Include Directories → Edit
and add your custom include directory here

It should look something like this.

I think the directory you add here is relative to the directory the .sln file is located.
You probably could add the Absolute path as well if relative pathing is giving you grief.


Thanks for reply

Property of UE4 project is a little bit different because of using UBT (as I understand)

When I add include directory nothing change. Project can`t be buit because of:

Fatal error C1083: cannot open include file

It seems that I make misstake in path (skip one directory). Now it works fine as

Your right, UBT is different, I am a little out of touch with how UE4 handles its dependencies it seems. For regular programming it should work. Glad you managed to get it working :slight_smile: