How get the disable depth test effect with custom depth test?


I’ve implemented a post process in where all the scene is desaturated except the meshes with custom depth enabled. This geometry is rendered with its original material. Now I want just some of the object with custom depth appear on top of all other either if they have or not custom depth. How can I achieve this?

In the bellow image yo can see my problem, in where the sphere must be rendered always on top like when you use disable depth test in a translucent material.