How force UE4 to use just visual studio?

no matter what I do UE4 run visual studio 2015 on my pc.
Edit->Project Settings-> Platforms-> Windows → Toolchain ->CompilerVersion. i did this but its not work .

how can I force it to use 2017 only?

Hi, as far as I know, unreal tries to use the oldest visual studio installed, and the only way is to have only one studio. That, however, can be untrue, but it’s how I usually deal with it.

UnrealBuildTool have a -2017 and -2015 options to force version, try generating project files with that option

https://docs.unrealengine.com/en-us/Programming/UnrealBuildSystem/ProjectFileGenerator

Appertely it makes UBT compile in that version too, but if not look up in project settings in VS, in NMake section there sould be custom UBT build commands an add -2017 option

Note that UBT use VS only for compiler and VS IDE it self is just use only as text editor, any compilation configuration there is ignored and UBT only follows build scripts (*.cs files in source directory)

Hi Shadowriver . thanks for your fast reply and please accept my apology for my late reply.
I cant find the file I must add -2017 command in it, can you give us more detailed description cause I’m really new in C++ especially in unreal.
i found UBT file in this address : :\Program Files\Epic Games\UE_4.18\Engine\Source\Programs\UnrealBuildTool\DotNetCore
if its that file just add -2017 is it enough?
thanks.

i find out i must edit this file :\Program Files\Epic Games\UE_4.18\Engine\Saved\UnrealBuildTool\BuildConfiguration.XLM

I add -2017 with text editor in it and I did generate visual studio file again and it doesn’t work still, UE4 continue run 2015 version.

<?xml version="1.0" encoding="utf-8" ?>
<Configuration xmlns="https://www.unrealengine.com/BuildConfiguration">
</Configuration>
-2017