How do you regenerate the Landscape Collision, as its not matching the terrain

Hello, I Created my Open world Landscape through importing of Height-maps for the terrain, it uses the World Partition Component for automatically streaming the tiles.

The Problem is that when I had modified the landscape to improve the shape, detail, it has left the collision offset, as when I test play the scene, my character will suddenly climb up invisible ramps and hit invisible walls, How do I rest these colliders to match my modified Landscape. Is there a simple way to re-bake the Collision on my Landscape, and anytime I make up extensive modifications, that I could just re-bake to match up the collision?

I have made a few searches on the forums on similar issues that other people had experienced however the fixes I hear about, include ideas such as duplicating the terrain then deleting the old one for it to recreate the colliders matching the second terrain. I think another one was to copy the terrain to a new fresh scene.

However as this is not a single landscape and is an open world using World Partition, I am wondering what would be the best method to re-bake the colliders for all of the tiles, like as it had been when I first imported the terrain but to match the improvements of the terrain.

I have been all over the settings trying to figure what could be done to correct this issue, even looked into the Bake menu, but I am not sure what and if any of those Commands would correct the Landscape Terrain Colliders.

So how would I be able to correct this and synchronize those colliders with the Terrain?
And hopefully without having to re-apply the Vegetation etc.

Please let me know what there is that I could do and if there is an easy setting or function to correct this issue. As I am using the UE 5, most of those other articles related to UE4 so I have no idea on if this may have a easy fix by now, that I may not be aware of.

I have also been getting this Warning when I switch to any of the other view windows in the editor when in Landscape mode it will show this warning “Landscape Physical Material Needs to be Rebuild (424 Objects)”
And after researching on this I saw someone had suggested to load up all cells in World Partition, and then on the build menu, select “Build all Levels” which also wanted to save everything first. But when I tried, and its log went through, It crashed Unreal eventually, Once I returned and tested, the problem above was still there, unchanged.

As I view in the “Player Collision”, its still unresolved with colliders where they should not be.
What else could I try to resolve this issue?

1 Like

I have the exact same issue using UE5.1.1
Landscape in World Partition, using Nanite Landscape

1 Like

I have had the same issue for a few months now. I had brief luck exporting the landscape as heightmap, and then reimporting it to create a new landscape, but the mismatch between visual terrain and the collision returned. And, you lose your paint.

For me, it shows the terrain in the editor where the collision actually is. But, when I run the game, it displays some older version of the landscape, while the collisions are still where they are in the editor. This results in landscape grass objects floating above the terrain.

Anyone have a fix for this?

You can export and re-import that as well.

Try deleting (after checking what to exactly, dont blame me for loss of data) your saved folder stuff so that the engine is forced to re-generate all the files for the project to run.

I sort of wish they’d finally add a built in “clean solution” button like all major editors have, so one wouldnt have to go manually deleting folders and such…

If that doesn’t fix it, then there is some other issue going on that’s causing the missmatch.

If using Nanite - which is still around Alpha so you shpuldnt be using it except for testing - the missmatch is fairly normal apparently.