How do you hide comment bubble in materials?

In regular blueprints, you can hide comment bubbles by disabling “Show comment bubble when zoomed”. Pic

But this does not exist in materials:

How do you hide comment bubbles in materials?


Not possible at this point.

UE Basically said its there to keep the comment visible no matter how far you zoom out.

Its annoying and I hear rumors that there is a plan to allow it to be turned off but I cannot confirm this.

It took them a bit to allow it to be turned off in regular blueprints.

give them time I am sure that change will eventually propagate to Material Editor as well.

1 Like

Is this still unchangeable in 2021?
However the far away you’re zoomed you can still see the comment-box – Thats good enugh.
Atm. UE 4.26.1 you still have a comment with at comment, thats redundant. Its like an extra footnote-footnote saying: I’m a footnot. i can see the point in this answer, but then, why not simply let the comment headder grow and overshadow the nodes if everything is that small, you can distinguise the nodes anyway

Oh I know it’s horrible. This seems like a serious oversight. It make it very difficult to read when you have lots of comments. MAJOR distraction

1 Like

Can just agree this is a slight annoying thing when you create comments with scaled up fonts for overview and description inside a hectic material and seeing double info just clutters things up… Moving nodes so far apart just to keep your sense of tidyness in check to have the bubble not overlapping anything else, the node structure becoms ridiculous to read while zoomed in.

Please add a tickbox to disable this feature even in materials.

1 Like

Please UE Devs, give us the opportunity to hide the comment bubble popup in material event graph… :slight_smile:


Up to UE 5.1 and this still has not been changed… :frowning:


Hey, this plugin works pretty well.

Auto Size Comments

1 Like

This doesn’t help for this issue, sadly. We’re looking for a way to hide the Bubble above comments inside the Material editor. There don’t seem to be any features in the Plug-In that enable that.
I just gave it a try, and it’s a cool Plug-In, but sadly doesn’t help with the issue :confused:

I found this thread in an internet search for the same issue, and it looks like that plugin does indeed hide the comment bubbles now.

There’s a checkbox for ‘hide comment bubble’ and I tested it today. It works :slight_smile: