How do you get MSAA working on Vive?

How do you get MSAA working on Vive? I’m working with UE 4.14 have set to forward render and set AA method to MSAA. If I set the r.MSAACount above 1 it’s obviously not doing any AA. At 1 or 0 it does TXAA which at least looks decent. Is there some trick to get MSAA working with Oculus/Vive in 4.14?

Have you read the documentation for the Forward Renderer?

Yes I have read the documentation and followed the instructions on 4.14.3. I have forward rendering, I have MSAA set and if I set the r.MSAACount to anything past 1 it looks the same as with no AA. Does it only act at 4/8/16 or something? I’ve tried many numbers but only 0 or 1 look (TXAA) look like any AA is applied. All of the other numbers show extreme stair stepping/pixel dancing. TXAA looks way better but extremely blurry.

MSAA only works at multiples the hardware supports. On most cards that is 4/8. Setting r.MSAACount to 1 with MSAA enabled drops back to TAA - useful to use to compare the settings while in VR.

I’m testing it. Forward shading on, MSAACount any value (4,8,16) as 1 (nothing).

Has anyone been able to turn MSAA on the VIVE?

update: msaa count 16 resets to 1. On the 8 - far distance objects looks bad than TAA , but close ones good

MSAAx8 Vive Test MSAAx8 Vive Test - YouTube
TAA Vive Test TAA Vive Test - YouTube


This might be a bit late but I hope it might help someone in the future. I created a video explaining how to enable MSAA (multi-sample anti-aliasing) I would keep the msaa count as the default, I find that is the best quality for VR and also defaults to disabled when trying to change it.

check out my video for more information. It’s also good for getting more performance out of your project.

Hope this helps,

1 Like