How do i zoom in Ortho view beyond 10cm?

Hello, when i use the mesh editor and put it in an ortho view i can only zoom to 10 cm, is there a way to bypass that limit? Thank you.

I would like to know as well as currently max ortho zoom factor is hard coded like this:

 #define MIN_ORTHOZOOM	250.0	/* Limit of 2D viewport zoom in */

So there is probably no way how to modify this without doing engine recompileā€¦ This is very lame. Same with editor default grid, which is most elementary thing in engine to customizeā€¦ Hope they fix this in a way it is externally accessible either via setting or consoleā€¦ For 4.15 and 4.16 this is not user select option. I do have small items as well and this is extremely anoing to not be able to zoom in enough. @Epic please fix this ASAP it is really anoing and impractical.

To change that limit edit that number to your liking. I changed mine to 25.0, rebuild engine and my problem is now fixed. I can zoom in to 1cm now :slight_smile:

Thanks for the answer :slight_smile: it would be nice to have that in the engine settings !

Just checked in 4.22.3 and things are still the same. I modded engine so now this is made public in editor settings viewport preferences (Advanced Display option). I think Iā€™ll submit pull request as this is annoying thing and quite common question. Need to test it more so Iā€™m sure I didnā€™t break anything.

Sounds good :slight_smile:

for future seekers:
Editor preferences: Viewports - Minimum Orthographic Zoom (default 250; set to e.g. 10)

1 Like

Thank you!