How do I VR desktop window adjust?

Gots a little quesiton and wondering if anyone happens to know. When I’m running a VR game and there is that secondary render window on my desktop that shows everyone what it looks like through the headset.
Does anyone know how to change the resolution of that window so its not tall and skinny?
ty ty for any help

execute console command “hmd mirror mode 4”

this command has 5 values (0-4):
3=SingleEye Letterboxed,
4=SingleEye Cropped


I am probably not up-to-date, but does this now work with the vive too, or just with the rift? since at least up to 4.13 this only led to a black screen on the vive / with steamvr…


I been asking this for days. Thank you for asking as well.

And thank you for the help Mamoniem :slight_smile:

Oh heheh I misread thing so let me rephrase.
Thank you both so very much. This is perfect :smiley:

And just got home and tried it out. Sadly now the secondary render window is only showing black. Even when I remove the console command completely its still stuck as solid black. I also am testing on a Vive. Any ideas are very truly appreciated. :slight_smile:

So I seem to have found a kinda sorta fix. First what you have to do is

Go to your project folder -> Saved -> Config -> Windows -> Engine.ini



So the 0 is either 1 or 2. 1 for a mono view, 2 for stereo view.

That will get your single or double mirror window working again.
Then if you do only want the one screen but want to change the resolution. Open your level blueprint. On the EventBeginPlay chain add a
“Execute Console Command”
with the command set to
“r.SetRes 2160x1200”
or some resolution of your choice. It kind of works. Kinda. It still has the funky ratio but it can get bigger and small at least.

Personaly I’m goin with the
and no resolution change

Hope that helps :slight_smile:

Those the commands for Rift. Vive have another shorter list of commands. I don’t know what exactly, But I’m sure searching the forums or the AnswerHub, will find them quickly.


The problem with the commands for steamvr is, that you cannot really change the resolution. There are settings in the ini files for SteamVR Mirror resolution, but those didnt work when i last tried them.

So it somehow seems that the vive is still a second-class citizen, and its a bit hard to record gameplay videos for VR with this aspect ratio…


Got your point. This is back to the Engine code itself, so If you are experienced with C++ and the engine source, you might figure it out easily.

But if you don’t, then I recommend you to get the source code (Zip or Fork) from Github. And do this modification:
Or you can follow this reddit post, it does almost the same thing:

this should help you having a fullscreen desktop window.

1.Check the video first, to make sure this is really what you want.
2. Vive is not a second class person or something :smiley: But Oculus integeration was done by the Oculus team themselves (as far as I know), and they are keep maintaing it and merger things to every new engine release, so this is why it is always uptodate and have better features than Vive

Nice! Thank you so very much for this. You are Elvis!
Going to try it out tonight :smiley:

Side note: If someone from Epic reads this and has some pull to suggest putting easy to control features like the Oculus has for this area, but for the Vive, Me and a bunch of others would realy realy apreciat it :slight_smile: