Download

How do I use my own Lightmap?

I have made my own lightmap because the one that UE4 was not to my satisfaction, uh, statisfactory(?).
What I mean is that I was not happy with ‘lightmap density’ so I made my own!
However, I am having a weird problem where I cannot make it work. Well, sometimes.

Okay, let’s see, it has 3 UV maps:

  1. The one for the texture.
  2. The lightmap UV that I made.
  3. The lightmap UV that UE4 generates.

So, I set the Source Lightmap Index to “1” and the Destination Lightmap Index to “2”, with Generate Lightmap UVs unchecked.
It works fine the first time. However, if I exit and open it again and make it build the scene, then it goes back to the the generated one.
When I go to the, uh, “Static Mesh Properties”, it’s still set to “1” and “2”, like I did before, and if I press Build again, it just shows the generated one, again. So I have to go and set it to “0” and back to “1”, however that makes it crash, sometimes.

I looked around to see if somebody had the same problem but I am not sure if it’s the same problem as this. source lightmap index reset to 0 - UE4 AnswerHub

Thank you for reading this and for the help!

Uh, I am not sure why I posted it here. Can somebody, please, move it? Thank you very much! ^_^’

I guess it’s the lack of sleep. :stuck_out_tongue:

Make sure you know what you’re actually wanting to do–there’s a difference between a lightmap UV channel and a lightmap. In 4.5 UE4 has an option to automatically create a UV channel for lightmaps when you import objects, if you don’t want it to generate it for you then turn it off. By default, if you have a second UV channel then it will use that for the lightmaps, if you have only one UV channel then it will use that. If you’ve imported something with only one channel, and then reimport it where you’ve added a second channel then you need to open the static mesh and set it to use the correct UV channel for lightmaps because it will not adjust automatically.

Thank you very much for you reply! Thank you! I will try that…uh…well, I think, that the problem was that I had to set it to the same channel as the lightmap? So, that my own lightmap (1) was both the source and destination? Maybe? :slight_smile:
But I will try what you said, as well! :smiley:

You can’t use your own lightmap, you can use your own lightmap UV’s

Oh, yeah… Oopsie, I have been referring to the UVs the whole time. ^_^’ I am simply too tired to think clearly.

Well, that’s what I have been meaning to refer to, I meant to say. :slight_smile:
Oh boy, this is going well. Maybe I should just call it a day! xD I am typing nonsense here.