Download

How do I turn off compression for textures?

Hey guys,
I am noticing that the albedo textures are getting a little blurred in unreal compared to marmoset. I understand its a game engine and always needs to compress to save running out of memory.But I really find the textures in marmoset to be very crisp and it will be very handy if there is any option in unreal to switch off compression for showcasing artwork.

Double-click a texture to open the texture settings, and underneath the compression tab, pull down the dropdown menu and select TC_VectorDisplacementMap. As far as I know, it’s uncompressed.

Hi mariomguy ,

Thanks for your answer.

I tried with TC_VectorDisplacementMap but the output still remained the same.
Is it something else I need to do other than saving after the settings are changed?

TC_Vector DisplacementMap should be uncompressed. I think you might be having issues with texture streaming, where textures start streaming into the game at the lowest mipmap. I think you can disable texture streaming from the texture properties, and you can also disable mipmapping as well. But a word of caution for mipmapping, your texture will be very sharp and highly aliased without any mipmapping at all.

If you really want the texture absolutely uncomressed, choose “EditorUI” as compression setting.
This preserves all channles in full resolution.