How do I stop eye adaptation brightening the night sky (space)?


I’ve been working with a DDS import (TextureCube) of a space sphere with stars and nebulae. It looks great in the viewport with eye adaptation turned off, but when I run the game, all the black (or very, very dark blues/purples) slowly becom very, very visible blues and purples… The difference is huge and I can’t see how I can just reduce the brightness of the source image, since it is already very close to black.

Basically, I want there to be no or little effect of E.A. no the sky sphere texture. Any ideas?

Thanks in advance :slight_smile:

Hi Astravagrant,

You’ll need to add a Post Process Volume to your scene and then adjust and tweak settings from there. This documentation on Eye Adaptation will give you the information you need to adjust it to your preference.

Thank you!


That’s awesome, thank you very much!