How do I stop an object being lit from the back faces plus decal problem

Hi, I’ve encountered a strange artifact where my material/object is receiving light from it’s back faces and decals don’t work.

On the left is how it looks when lit from the front (no artifacts, decals where they should be), however I want this side to be in shadow. When when I rotate the light to put it in shadow, it seems to be lighting from the back, and I get specular highlights where there shouldn’t be any, plus my decals disappear, as shown on the right.

I have tried checking and unchecking “two sided lighting” in the object’s properties, as well as “two sided” in the material options, but neither seem to make any difference

My object is one sided and looks like this from the back

Does anyone know what could be causing this? Does the mesh need to be “water tight” and not expose any back faces to light? When I imported it into unreal (from an fbx) it said that that It had “degenerate tangent bases” so I checked “rebuild tangents” in the object properties. I also experimented with other tangent settings in the object properties, but nothing seems to make a difference. Could it be a problem with my normal map? I baked it out of 3ds max, and it seems to look fine in Crazy Bump, as well as any areas that are lit from the front.

Thanks in advance to anyone who can help!