How do I stop a navmesh from generating inside a static mesh?

I have made actors that are comprised of a cube shape component, and a cube shaped static mesh component.
The cube actors have been spawned in a grid to form a larger cube. (10 x 10 x 10)

The plan is to cut out rooms for the units to run around in.
But the navmesh is lagging everything out as far as I can tell.
I noticed that a navemesh is generated inside every single cube actor…

In this image I am inside one of the cube actors.
You can’t see the cube you are inside because its material is not two sided.
But it clearly shows the small square navmesh within it.

Is there a way to flag an actor, or component in an actor, to disallow a navmesh to be generated within it?

Figured it out. A NavModifier in the components list set to Null did the trick.