How do I set a specific pawn to ignore custom dilation?

So I’ve set up a blueprint that spawns a sphere that when actors enter through it, their time dilation set to 0.1, rendering them effectively slowed in time. However, I would like to have it the player actor is not affected by this effect, how would I go about setting it up?

Here is the code for the sphere itself: