Download

How do I remove the "Lighting needs to be rebuilt" prompt?

I have created an animation that I need to render off and it doesn’t matter, at this point, the the lighting hasn’t been correctly built… I just need to record the animation through Matinee.

I did some research and found I can remove it by using DISABLESCREENMESSAGES command, but where do I enter that?

I know it won’t solve my problem with the lighting, but I do need to get the animation out by tonight and I can’t spend the hours it will take to build the lighting (has already taken 2 hours and it’s only at 1%

I’m guessing it goes in the console, press ` =]

Thanks for the reply, Xerithas, but that didn’t work. I hit ` and it opened the console and I entered the command then hit enter… But the render still gave me the prompt =(

Two consoles. Did you enter it in the PIE console or in the play viewport? When you hit play drop the console and should show up in the list the moment you type DIS…

Thanks, FrankieV, I’ll give this alternative choice a try next time. Unfortunately I have passed the deadline for the animation but this is good to know for the future.

if you dont care about having the lighting correctly built - world settings -> lightmass -> lightmass settings -> expand the little arrow at the bottom -> force no precomputed lighting

where is this option ? I do not see it in 10.1 and I would also like to ignore the lighting needs to be rebuilt tagline

Another temporary option would be to make the things that aren’t baked Movable as opposed to Static. They no longer need to be baked and therefore won’t prompt the message.