Download

How do i prevent this shadow

Hello,

how do i avoid those shadows from the object when the Sun is behind the Wall?
I know those objects are not solid but how do i prevent this shadow from the backside of the object?
The Shadow everywhere has these holes and I do not want to have them.

Thanks for your help!

if you need shadows from single-sided geo, enable two-sided in ts material

I did this but the effect remains the same

Thanks a lot for yiur answer.

I´m sorry but what do you mean with ts material? Texture Setup?

Got it!

To cast a shade you need actual geometry. Period.

Ment to say in its^ material, not ts :slight_smile: Two sided materials shade the backfaces and flip the normal for lighting calculations, that way you don’t need to have actual geometry on both sides to cast shadows.

But you do still get artifacts, poor distance fields, and possible glitches.
Closing the mesh up is probably preferable in the long run.

So, am i wrong? Ok, what i´ve to do to not project shadows with holes in it?
When i tick in the Material two sided option and save it then nothing happens.
It´s really confusing to me.

The Meshes i´ve got from Quixel. So i´ve no chance to close it up.

Ok, i think i got a solution. I did it like ixicalibur has mentioned it in the post above.
Editet the Material instance from the Object(Mesh) to two sided and this works too.