How do I move Unreal Engine's Folder to another drive?

I’ve looked through the Epic Games Launcher and Unreal Project Browser, but can’t seem to find a feature to migrate all of Unreal Engine’s files out of my C: drive. I’ve also Edited my Vault Cache Location to another HDD, but Unreal Engine keeps saving data in the DerivedDataCache in its default folder.

Is it safe for me to drag the entire UnrealEngine folder to another drive, or is there a safer way to do it without entangling the directories?

Cheers

5 Likes

I tried to move it several times (because I have four versions installed and they occupy a lot of space), the best solution I found is to fake the location using a symlink:

  • Close the epic launcher

  • Move the engine to the desired folder (Cut the UE_5.0 folder)

  • Open the terminal in the folder where the Engine was located (Video below) and then type mklink /j "UE_5.0" "D:\NewPath\UE_5.0" (D is the letter of the drive where you moved the engine folder)

  • Instead of opening the terminal in the folder you can also use the full path from any terminal:
    mklink /j "C:\Program Files\Epic Games\UE_5.0" "D:\NewPath\UE_5.0"

  • Now you should be able to launch UE from the epic launcher


If you want to move the “DerivedDataCache” folder and not the Engine folder (that is about 50GB) you can do it in two ways:

  • Save the DerivedDataCache in each project’s folder:
    1. Open BaseEngine.ini UnrealEngineVersion\Engine\Config\BaseEngine.ini
    2. Find: [InstalledDerivedDataBackendGraph]
    3. Change Path="%ENGINEVERSIONAGNOSTICUSERDIR%DerivedDataCache" to Path="%GAMEDIR%LocalDerivedDataCache"
  • Save the DerivedDataCache to a custom location:
    • Change the path in the third point to a custom folder in your system

Edit: You should be able to edit the path from the editor settings too

10 Likes

what do you mean by “cut” the 5.0 folder, please?
thanks

He means ‘Cut’ as in ‘Cut and Paste’ (as opposed to Copy/Paste which would leave a copy of your engine behind)

1 Like

hey thanks for the reply…it’s been difficult to install 5.0…it doesn’t install to the original
C:\Program Files (x86)\Epic Games folder…it keeps saying the path is too long?!?
so I need to install to a new folder on the desktop…
ideally I would like to then transfer to the Epic Games folder, but then the launcher doesn’t find it…
couldn’t really make it work with the command above either…

Hi everyone, seeing some new activity here, just wanted to leave out the solution that worked best for me.

Ares9323’s advice was and solid, however I screwed up the execution, so instead went with the frustrating and boring option of reinstalling Unreal Engine 5 in a new drive entirely. It’s not ideal, but it solved the issue of trying to relocate the DerivedDataCache folder.

If anyone has a better solution, you’re more than welcome saying it. Many would love to hear it.

Cheers.

2 Likes

how did you installed in a different folder?

As I previously stated, I deleted UE5 and reinstalled it into a different drive. If you’re technically savvy, you could try to replicate Ares9323’s advice.

yeah but did you uninstalled the epic games launcher and then move it to a different folder? I have the 4.27 version which i want to keep it where it is.

Ah, no I haven’t. It was already installed where I needed it.

Unfortunately you’ll have to uninstall the launcher and reinstall it. This page should help you.

Side note: Settings >> Edit Vault Cache Location // If you are trying to install content like City Sample and you do not have enough room on your C drive.

3 Likes

Found this on Reddit: how can i relocate unreal engine to another drive ? : unrealengine (reddit.com)
Seem like the best solution to avoid uninstalling and reinstalling. Trying it now, I’ll update if it works!

Edit: I couldn’t get this to work. The Epic Games launcher seems determined to not change the UE path for anything. I even tried starting the install, killing the Epic Games launcher via task manager and then copying all the UE5 files into the install location instead of the in progress install folder. When I open the EG launcher it still wants to resume the install… I’m out of ideas at this point…

Hi, thank you for the post! It works for me! I want to add a little bit from @Ares9323’s symlink solution. You need to add quotation marks (") around the paths. So it should be like this. Don’t forget to adjust the path.

mklink /j "C:\Program Files\Epic Games\UE_5.1" "D:\Epic Games\UE_5.1"
4 Likes

Thanks for the add! I forgot to mention that quotation marks are necessary if you have a space in your path!

Can you explain What is Terminal

I tried the- "mklink /j "(ARES9323) solution- which works for me.

BUT
here is another solution- may be simpler and more “clean”:
go to: %LOCALAPPDATA%\EpicGamesLauncher\Saved\Config\Windows\GameUserSettings.ini , and inside the text file change DefaultAppInstallLocation parameter accordingly to th new path you pasted your engine to.

Hope it helps

2 Likes

Hi. No, this solution doesn’t work… Obviously this is only for new installations

There is no way this is that difficult… how can you not have an option in Epic to change the folder/file path?