Download

How do I make a "tempered glass" material like this?

Hello, how are you guys?

I’m trying to recreate this glass material from ArtStation (“Glass_Ref.jpg”), but I can’t find the best solution to this… I’m kinda new with materials in UE. As the project shows, the artwork/poster is pressed between two panes of glass.

So far, after mixing some tutorials from youtube, I came up with the shader from Material_Ref.png in a rough exterior environment example (node graph is in material-nodes-01 and 02.png). I used a spot light and some emissive lights behind me to try to replicate the effect, but with no success.

I want to make exactly the same material: a tempered glass with little or no refraction, “see-through” and with a little bit of reflection, where I can put a poster/arwtork in the middle of them. Please, can you guys help me?

(By the way, the poster has a single diffuse, specular and roughness material.)




So… what’s the issue you’re having specifically? Lack of reflections perhaps?

You wrote about what you want but nothing about what you feel is lacking in your own approach…

Honestly I can’t make any sense of your material. You’ve got specular default set to 26 and roughness at 0.5… specular is capped at 1 and a roughness of .5 will produce extremely blurry reflections. I have to assume these are not the values you’re actually using… Your fresnel opacity goes all the way up to .9? What is it you’re trying to achieve with this graph?

My advice would be to first of all make sure you have reflection captures in your scene because otherwise you won’t be reflecting much of anything. Ideally you should have a somewhat representative environment to test in rather than an empty map, but that’s probably not really necessary.

Start over with a new material, use the Thin Translucent shading model with translucency mode set to Surface Forward. Create a thin translucent output node, this will control the translucency color. Keep this near white (don’t go over 1) to preserve the color behind the glass. Set your roughness to something low (0.05~ perhaps) and make your specular a scalar parameter, tweak it to taste (but remember… it doesn’t do anything over a value of 1)

Actually, your reply pretty much helped me a lot! Thank you so much. I’ve tweaked some more parameters and watched some more tutorials (this one is perfect) and finally made it work. Also, the raytracing translucency is essential for this to work (on PostProcessVolume).