How do I get the event dispatcher out of (read-only) mode?

I don’t like to repost things but I can’t find the answer anywhere, and this is preventing me from learning UE4 any further. How do get event dispatchers out of read only mode?!

I am not sure what you mean. Event dispatchers must be called from somewhere else. The one you see in Blueprint editor is there only to specify its signature (what are its input pins - like an interface function).
The actual logic must be given somewhere else.

Take a look at the Bluepritn communications sample and this:
https://docs.unrealengine.com/latest/INT/Engine/Blueprints/UserGuide/EventDispatcher/index.html

Now I have posted a blueprint whcih uses dispatchers in the follwing Thread. Scroll downn a bit and you will see my answer with several blueprints. It shows how a Dispatcher is being called.:

So the general process is:

  1. Define a dispatcher and specify what its input pins are. (this is what you have done at the moment). You cannot add any logic here.
  2. You must bind a function (event) to the dispatcher somehwere (usually in another blueprint). YOu can bind multiple functions to a dispatcher. When the dispatcher is called, all those functions will be called. NOTE: The functions being bound must have the exact same signature as the dispatcher itself.
  3. Call the dispatcher. This is to trigger the execution of the bound functions. Think of it like a notification that something has happened. All functions bound to this dispatcher will be called here with the parameters being passed into the dispatcher call.

better explain me with a photo

Hey, I just started out with Blueprints. I’m facing the same issue with the Player Controller blueprint in the default top down blueprint game. Same issue here, I’m not able to test anything out as the Blueprint is Read-only. I haven’t seen this issue raised anywhere else, so I just wanted to know if you found what the problem was in your case?

Also I’ve noticed now that when I tried this out in my own custom project or the marketplace projects, I didn’t face this issue. Even the default FPS project was not having this issue.

Edit: Sorry I made a silly mistake there, the blueprint became read-only because my level was already running in the editor. I just stopped it and now I can edit the blueprints.

same issue here. I can’t even define a dispatcher cause no buttons are working…

Hi, all. I’ve faced the same problem. For testing purposes I created a Blueprint Actor and created an Event Dispatcher inside of it. Next I wanted to add some inputs to our dispatcher in order to transfer some data through variables but I couldn’t because buttons were grayed inactive and blueprint event graph viewport had “read-only” overlay. Screenshot was attached. Thx in advance.

@MichaelGotti Do not double click the dispatcher. Close this tab and single click-select the Test event dispatcher in the bottom left. You should be able to add inputs in the details panel.

1 Like

Thx for answer. But it doesn’t help. It is weird because I’ve remembered that it should be very simple and clear to add inputs and there is shouldn’t be a problem work with dispatcher. I did it maybe 2-3 months ago but don’t understand why I’m not able to do it right now :slight_smile:

Also I did the same in UE4 - the same result. Maybe I forgot something…
Screenshots were attached.



You’re not supposed to do anything inside the dispatcher - it wouldn’t make sense…

As it wouldn’t with an interface.

1 Like

Thx a lot! Thx for your patience! :pray: