Download

How do I get initial particles to remain when the emitter is deactivated then reactivated?

Hey,

So I have a jet pack on my character. I have setup blueprints to activate the attached particle effect on a button press and then to deactivate when the button isn’t pressed. The trouble is that when I The press the button again, all the particles that have just been spawned in the first press, disappear. This is very noticeable if you are rapidly pressing the button.

Is there a way to have the initial particles persist through a reactivation of the emitter?

cheers

Instead of toggling the visibility of the whole particle emitter, you can set up a parameter and control the particle emission rate from your blueprint. Just set it to zero when it’s deactivated. I’m sure there are other ways to do it, but I had the same exact problem and this seemed to work.

This is probably your best bet. Also saves a bit in the render department since you’re not going have those particles hanging around and the particle isn’t still ‘emitting.’

(At least, thats how I understand it)

hey,

Thanks for the replies guys. I have managed to get it working. but now i have another problem that has arisen from doing things this way. Now, when the game starts the jetpac is already set to the maximum particle rate, as if the button where pressed. If i press then release the button, everything works perfectly from that point onwards. I think it’s because I had to set the emitter to auto activate. Do I have to set up an activate node somewhere in one of my blueprint graphs? I’m not sure where it should be. Or is there a way to get the default rate scale (this is the parameter I’m changing) to be 0 on game start?

Nevermind. The constant value was still set to one. I guess this was so i could see it while editing it. I set it to 0 and everythign appears to work perfectly no

:smiley:

There’s a tick box somewhere that has “Start Enabled” somewhere under details too, iirc.