How do I fix overlapping UVs after converting a geometry brush to a static mesh?

I made a simple box brush and applied a material to it. Then I converted it to a mesh. Now when I build, I have overlapping UVs.

I feel like this really shouldn’t happen with simple brushes like this, so what did I do wrong? How can I fix it within Unreal and not exporting to 3DS Max etc? I made it in Unreal, after all…

Answering my own question in case anyone else has this issue:

  1. Double-click the mesh in the Content Browser.
  2. Click UV in the toolbar, between Binormals and Additional Data. This shows the current UVs. They’ll probably look crazy.
  3. Go to Window → Generate Unique UVs.
  4. A tab will open for the Unique UVs, probably below the Details panel.
  5. On this tab, hit Create New. Save Results to UV Channel 1. Limit Maximum Stretching 0.0. Limit spacing stay at default 1.0.
  6. Hit Apply.
  7. In the toolbar, there’s a dropdown for UV Channel that’s set to 0. Select UV Channel 1 now. Your UVs should look more organized.
  8. In the Details Panel, scroll down to the Static Mesh Settings sub-section and find Light Map Coordinate Index. Set this to 1 because we made the UV for Channel 1.
  9. Hit Save in the Top Left of the window.
  10. This seems to be as good as Unreal will generate it.

Note: It could still look bad, at this point you’ll have to fix it in 3DS, I guess. I don’t see a way to edit UVs in Unreal other than generating them.

Kudos for being that guy who goes back to answer his own question so others will know. I’m sure this will be of great use to someone :slight_smile:

Indeed, was helpful.

Glad I could help! :slight_smile:

thanks mandilorian,…really helpful…yea im quite confused myself at first…
all I can do after applying 2nd UV and still have the error log message…(rightclick the static mesh) and use “create Blueprint using…” to fix the error log message…

This helps with some things, but for complex meshes I get “GenerateUVs failed, couldnt convert to a D3DXMesh” I wonder how to fix this

The Generate Unique UVs tool in UE4 is very limited, and will struggle with more complex meshes. Even with simple meshes, the tool isn’t the best option. Generating your UV mapping in your modeling software and importing is going to produce the best results.

So whats the point of the brushes if you cant use it for statics meshes uvs problem?

Nice one! I have just encountered the same issue using a number of mesh actors and converting them into a single mesh. Had a feeling it could be something like this so you just saved me a few good hours. Cheers